[Dev Action Needed] -Surround/Eyefinity/Ultra widescreen bug



  • I run 3 monitors in Nvidia Surround setup @ 5900 x 1080. The unreal engine is scaling fine and the cutscene I have seen so far is centered correctly but the menus and game play are zoomed in as you can see by this screen shot. I have had a play with some ini settings and console (the Scale UI settings affected the gold fuzzy edge you can see on the right with it appearing along the bottom of the picture as well) but have yet to find anything that helps. It is not related to FOV.
    [attachment=0:zj7kkm0h]2012-09-17_00001.png[/attachment:zj7kkm0h]
    Any suggestion on what to tweak to get it sorted ?

    I am also experiencing a loading bug when I exit the tutorial back to the menu, it just sits at the loading screen and never completes.



  • Status updated - Good bug description and image!

    In regards to the temporary loading bug please refer to the following workaround here



  • I found out how to fix this issue. I hope the devs are ok with me posting this, I don’t see it giving people with multi-monitors an advantage because the FOV is best left at default anyway.

    It looks best in 3rd person, since in the 1st person camera view the arms are chopped off at the top (maybe the camera is inside the mesh?).
    Also the menus are stretched but work fine.

    So here’s the fix:
    Got to \Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config
    Open UDKEngine
    Find the section [Engine.LocalPlayer]
    Change
    AspectRatioAxisConstraint=AspectRatio_MaintainXFOV
    To this
    AspectRatioAxisConstraint=AspectRatio_MaintainYFOV
    Save and close

    These screenshots are at 5860x1080 FOV default (95?)



  • ALSO DO THIS in the UDKEngine file:

    Find the section: [UnrealEd.EditorEngine]
    Add this to the bottom: LevelViewFOVAngle=95.000000

    That fixes the messed up camera views in both 1st and 3rd person!
    But unfortunately the HUD is cut off the top and bottom of the screen now so if you don’t mind not seeing your health and stamina, then this is working perfectly.
    Now I must sleep ;) Enjoy



  • Well I’m going back to just using my middle monitor at 1920x1080 for now. While the above fix “sort of” works, its not the way its supposed to look. Way too stretched. I have my fingers crossed the devs can fix this problem.

    One other thing I think might help is if the devs allow higher FOVs. Chivalry has a maximum FOV of 100 at the moment, but I think allowing up to 140 could work well enough without the need for any further fixes.
    At least that what I gathered from reading a bunch of forum posts about Unreal Engine’s FOV/Aspect Ratio implementation.



  • guys, i got it working, so heres step by step instructions

    1. navigate to X:\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\
    2. open UDKEngine in a text editor
      3)search for the line of code that reads: AspectRatioAxisConstraint=AspectRatio_MaintainXFOV
      4)right below it add the line of code: AspectRatioAxisConstraint=AspectRatio_MaintainYFOV
      5)save the document
      6)start the game and adjust to the proper resolution
      7)enjoy chopping heads in multi monitor glory!

    Edit: and make sure you leave that space in the document in between the aspect section of the code, and the one below it.

    Edit yet again: you may need to adjust your FOV once you’ve applied the fix, personaly my screen setup worked perfect with an FOV of 70 ( you can adjust your FOV by typing “Fov XX”, into the console in game, XX being numbers)



  • …and you cant use the console in multi player anymore… so no fov edit unless your on SP, Devs need to add FOV adjust bar in options.

    EDIT: nevermind, you can use the console… it looks like if you punch in an invalid value it just does nothing, i typed in Fov 80, and tada, it works.



  • supdudefrog - Adding that line of code does the same as what I wrote in my posts earlier in this thread, it forces the horizontal ratio to fit your monitors but not the vertical. Which is why the HUD and menus are chopped off.
    Also, the FOV still resets upon player death.

    The issue still needs some Dev action to be resolved. Its probably not high on their priority list right now, but I’m hopeful!
    (I’m enjoying the game on one monitor for now regardless) :D



  • okay, well my HUD and menus are all 100% visible and working, but yeah the FOV does reset…



  • Hate signing up just to necro a thread, but after making the switch to a triple monitor setup, I’m a believer. I don’t expect an answer right away. The game is less than a week from launch, so this shouldn’t hit high on the agenda.

    I was wondering if any more attention had been devoted to fully supporting eyefinity or multiple monitor setups? Any info would be welcome.

    Game looks great! Day one customer and looking forward to it!



  • Playing with the new FOV slider in beta patch 4…

    For me, a FOV of 85 looks really nice used with the ini tweak described above (changing or adding the MaintainYFOV parameter).
    It looks just as good as the default FOVof 95 at 16:9, with one exception which is the menus/HUD: They still get chopped off at the top and bottom.
    This is becuase the ini tweak only ensures the Y aspect fits your monitor setup.

    Devs, if you can get the game top fit both the X and Y aspects at custom resolutions, it should fix the menu/HUD issue.
    As it is its quite playable, but still slightly annoying having the HUD cut off.

    Also I’d recommend having that ini tweak changed by default in the meantime as it is a huge improvement and doesn’t affect the game at standard resolutions.
    Thanks! :)



  • Has there been any progress on this?

    I’d like too see the HUD elements centered.



  • Hey guys, signed up to comment on this thread….

    Running Eyefinity 6100ishx1080 (bezel correction). Been using fov 110 in third person.

    The game is absolutely fantastic on triples. LOVING the game so far.

    SO, +1 for a HUD fix. Kind of have to guess what I am clicking on sometimes lol.



  • Hey All, Another 3x screen user here, Currently playing on a single screen until the FOV gets fixed for eyefinity. That would be great if someone has a better workaround or the devs release a hotfix :P



  • bastards and your x3 hax! :D



  • Dam your response, I thought you were a dev announcing a fix!!! :P

    @tracknumberseven:

    bastards and your x3 hax! :D



  • haha I wish, I thought I’d throw in a bump-in-disguise for ya ;)



  • So no fix for eyefinity/surround gaming yet? I love having peripheral vision in games, but need to be able to see the menu and hud as well. Any plans for a fix or a work around?



  • @Kalthios:

    So no fix for eyefinity/surround gaming yet? I love having peripheral vision in games, but need to be able to see the menu and hud as well. Any plans for a fix or a work around?

    My thoughts exactly.

    Do the dev’s know this thread exists, I wonder?



  • @Kalthios:

    So no fix for eyefinity/surround gaming yet? I love having peripheral vision in games, but need to be able to see the menu and hud as well. Any plans for a fix or a work around?

    +1… I’m still all about this feature!


Log in to reply