Unable to play due to freezing at load screen



  • So for a long time I’ve been wanting to play this game and I finally bought it with $25 of my hard earned money. I was understandably stoked when it was finished downloading, right when it was done I opened it ready to get medieval. Aaaand it didn’t work. It did the thing where it just stays at the black box after the banner, so I had to trudge through all of these forums to find the solution (Which may I just say REALLY? Your opening cinematic prevents the whole game from opening? Solid programming…). After fixing this problem I was very very excited to start playing. But once again I came to find out that the most medieval thing about this game is the programming. It freezes anytime I try to join/start a game or do training, but the sound continues. It never registers as having crashed and I always have to alt+tab out. I’ve tried every single fix that I could find, none of which worked. And the most disturbing thing is they don’t really seem to work for ANYONE, most of the people with this problem seem to just be boned without anything they can do. I mean seriously? I paid $25 for a loading screen and an ulcer? The damn source mod was programmed better than this. Needless to say I’m pretty cheezed off, I just want to play the game. I’m seriously considering trying to get a refund from steam. So this is kinda my last little shred of hope that someone might have a solution or something, since patching something that completely breaks the game seems to be too much for the devs.



  • Im glad someone else is havin the same problem! Very frustrating to have wasted money and time on this



  • What are your specs?



  • I’m running Chivalry on a 2012 macbook pro through parallels on windows 7, which I might add I installed so I could play your game…


Log in to reply