[SOLVED] Chivalry Mouse Lag / Acceleration / Float thread



  • I’ll try keep this post updated with ways that have worked to fix mouse lag / float / acceleration problems in Chivalry medieval Warfare.

    First, make sure the problem isn’t caused by fps lag by using the ‘stat fps’ command from the console (` key) and checking if your fps is stable and high enough.

    Then, try the following
    (You can do all of these in one go or step by step, whichever you prefer)

    • unplug any XBOX 360 (compatible) controllers before starting game

    • turn in-game mouse smoothing off

    • disable Enhance Pointer Precision in Control Panel>Mouse>Pointer Options

    • disable mouse acceleration in your proprietary mouse software (ie Logitech)

    • Open My Documents/My Games/Chivalry Medieval Warfare/UDKGame/Config/UDKInput.ini
      Alter all these settings:
      ViewAccel_YawThreshold=0
      ViewAccel_DiagonalThreshold=0
      ViewAccel_BaseMultiplier=0
      ViewAccel_TimeToHoldBeforeFastAccelerat ion=0
      ViewAccel_RampSpeed=0
      ViewAccel_MaxTurnSpeed=0
      ViewAccel_Twitchy=0
      ViewAccel_PitchThreshold=0
      ViewAccel_LookingUpOrDownBoundary=0
      ViewAccel_BackToCenterBoundary=0
      ViewAccel_BackToCenterSpeed=0

    If that didn’t work

    Some games (Chivalry included) don’t use raw mouse input, and will get mouse acceleration even if it’s turned off in windows/mouse driver.

    • You can disable this mouse acceleration the pro-gamer way with MarkC’s mouse acceleration fix for Win 7 & 8
      (includes check if disabling worked)
      This sets the used acceleration profile to be linear, so there’s no actual acceleration feel anymore, even though acceleration is technically still enabled. Works for all games that use this way to read mouse values.

    If those don’t fix the problem, please state

    • mouse sensitivity setting in game

    • your mouse DPI/USB rate settings

    • your fps min/avg/max while playing (‘stat fps’ command from console (` key))