Jumpy character and weapon models?



  • I’ve been trying to watch others videos, but I can’t tell if it happens for them as well. I experience a lot of jittery character models, and even in my first person my weapons will jitter around. I have a computer that is MORE than capable of playing this game on full graphics, and my internet is as good as the average player in most games (around 60-90 ping)

    Is this something that went bad with my install? Or is this just part of the game? It really bothers my eyes.



  • Lots of players swingdrag, or lean heavily, which can disassociate the actual hit from its animation making it much more difficult to parry.



  • @JCash:

    Lots of players swingdrag, or lean heavily, which can disassociate the actual hit from its animation making it much more difficult to parry.

    Did you even read his post lol.

    As to your bug is it a constant jitter like a vibrator? I’ve seen that bug a couple of times but very rare.



  • @gregcau:

    @JCash:

    Lots of players swingdrag, or lean heavily, which can disassociate the actual hit from its animation making it much more difficult to parry.

    Did you even read his post lol.

    As to your bug is it a constant jitter like a vibrator? I’ve seen that bug a couple of times but very rare.

    I like, glanced at it. Bad day for my reading comprehension I guess. Never heard of that bug. Also wrong section right?



  • I see this when I spectate other players in first person, really annoying.

    Never had it with my own weps though. :S



  • It’s constant, 24/7 gameplay. Third and first person. Enemies and allies. I should fresh install then?



  • I’m not sure. I guess you could try it for nothing.

    Try different settings and so on too maybe?

    Also what are your specs? I know you mention your machine should be capable etc but heh, depends on the game. Also some powerful configs sometimes have trouble with things, not because they’re crap, just because that particular setup doesn’t like a game.

    But yeah I do see a lot of jitter when speccing, but never in my own stuff. :S



  • Obviously people did not read your post correctly and also i think some people are just less prone to picking up on microstutter.

    Which brings me to your question.It is NOT anything on your side of the game and put bluntly it all lies on the side of the developers.The issue is microstutter or frametime latency i suspect.If you mouse slowly you can pick up the mouse moves in what i would describe as blocks.After each block comes a jitter and a jumping of animations and onscreen text.

    Hell just look around the map and focus on the objective marker.They actually jump up and down up and down whenever the mouse is moved.It is terrible and nothing will fix it which includes internal framecapping with ini and msi afterburner, and neither will any number of max pre rendered frames.

    Im over specced for this game currently with a 3570k clocked to 4700mhz,16GB of DDR3 2133mhz and a GTX 580 backed up by a Raid 0 setup consisting of two Crucial M4 which give me almost 1GB sec read speeds for textures so how did they manage to screw up the Unreal UDK this badly? Dishonored was the same until you change the B_Maxsmoothframerate to 60 and min_maxsmoothedframerate to 0 but then it was one of the most smooth and epic game i have played in many many years.

    Chivalry on the other hand is downright abysmal when it comes to coding.It needs fixed and it needs fixed soon.Just watch spectator mode in first person for a microstutter so bad you will be sick within ten minutes.Even youtube and everyone i know can notice the objective marker stutter.Yet if you look closely its there all the time.



  • Forgot to say that if you really want to see how bad it is play the game without depth of field or motion blur.Max settings with all the blur actually hides the microstutter by 50%.Without it i would not touch this game with a 14ft pike.



  • Finally at least someone on this forum who knows at least something about cumputer science. Rdonnel i had opportunity to test Chivalry with 11 different setups. Well, 9 as 3 graphic cards were the same just different company. Used as low as machines with C2D T8100 with stock 2.1 GHz with GT8600GT/8800GT to met minimal system requirements. Up to 3770k with 7870 OC version. I also played on 3570k manually OC’ed. Overall results were very discouraging.

    @Milky
    At least now you will probably believe that some of us don’t just criticize without valid reason. Next time when you have question like this viewtopic.php?f=5&t=12703 i suggest you use other gaming forums where is less sheeps that defend their precious game mindlessly at all costs. Without knowing anything more than how to DL torrents during online gaming.

    edit/
    Just saying… but blur on sucks in games, in generally.



  • @rdonnell:

    Forgot to say that if you really want to see how bad it is play the game without depth of field or motion blur.Max settings with all the blur actually hides the microstutter by 50%.Without it i would not touch this game with a 14ft pike.

    Yup I had both off…… I usually really don’t like DoF and blur features, but at least I’m not getting sick now.

    EDIT: Also what is mouse smoothing in the settings? I would assume it has something to do with acceleration, but it’s not called that…



  • It should be set to mouse smooth false in the ingame options but it wont make much difference nothing does in chivalry.Ive tested pretty much everything a person can do apart from analyze its frametime latency with a dedicated video card capture tool like Nvidias NCAT which is never going to be possible.

    And when i posted in the technical support forum ive been told by two people that the game has no microstutter! I mean how can anyone with blur disabled say this game has no microstutter lol?



  • This really must be only on certain setups / settings. I’ve just switched Motion Blur off (I usually have that off in games by default but have it on in Chiv) and noticed NO stutter. Seriously the only time I see any is when speccing someone in 1st person, then it’s stuttering allover the place and looks horrible. Mouse Smoothing is set to False by default, I asked for that during Alpha. Was horrible inprecise otherwise heh.

    My specs:

    @BobT36:

    OS: Microsoft Windows 7 Ultimate x64
    CPU: Intel Core i7-3960X, 3.30GHz - (Hex-core, Overclocked to 4.2ghz)
    Motherboard: Gigabyte X79 UD3
    RAM: Corsair Vengeance, 16GB, (4x4096mb, 667mhz)
    GPU: NVIDIA GeForce GTX 590, 3GB (1535mb, 607MHz across two chips on the one card)
    PSU: Corsair 1050w - (Exact model unknown, probably a HX1050, can check if need be)
    Hard Drive: Samsung HD103SJ 1TB (260gb free) 7200 RPM
    Monitor: 24" Widescreen, 1920x1080, 16:9, 3D Vision

    Other Specs:
    Location: England, South Yorkshire
    Cooling: Corsair H80 Water Cooling (Processor Only)
    Connection Speed: 40Mbps Download, 10Mbps Upload - Broadband
    Speakers / Microphone: Sennheiser PC360 Headset

    The specs in the previous post should be more than enough to handle this though, which makes me think something specific is triggering it.

    Also Peacerer if that’s true, you likely had access to more test rigs than the devs… :P



  • Hmm well at least you can pick up on first person spec mode stutter which is a start.Are you subjective to it?

    And certain maps and settings will hide it.The map with the slaves is the worst one.And its not just motion blur u need to disable all the DOF needs to go so u can see the raw image.

    I seriously cannot play this game without all the blur to hide it.It is awful one of the worst things ive witnessed in gaming for 15 years.And people have claimed in tech support that there is no first person spectator mode stutter as well.

    So theres me who sees it in online and spec mode
    You who only see’s it in first person spec mode
    And another bloke who claims there is none at all

    My pc eats chivalry for breakfast in every department it can.Its driving me nuts that im going to have to go thru each gfx setting one by one.



  • Currently on Hillside. Disabled both Blur and DoF, using the Knight Halberd and looking around in First person, I see no stuttering. :S

    Possibly something in one of the configs causing it for you, I have no idea though, sorry. :(

    Either ways yes it looks TERRIBLE in 1st person spectator mode, and if it is like that for you all the time, I can see your pain heh. Bloody hard trying to watch someone who I’m speccing to see if they’re haxing, can’t see bugger all when they look left / right since it jitters allover the place.

    But yes I certainly have no problems in first person mode for myself.

    Just turned blur off actually since I think it looks BETTER with it off heh. It didn’t “stutter” with it on, but I did notice my weapon textures being blurred when I looked left / right quickly (I guess that’s what it’s supposed to do), and that gave the perspective of “flicking” a lil to me since my wep was flicking between blur and normal. With it off it just looks great all the time. Strange. :S Currently playing with blur off and DoF on. Mouse smoothing off of course.



  • Well i tried more fixes and its still there.Its not stuttering as such its microstutter which gives the impression of texture flickering.Its hard to describe but its still there for me.

    And to your question is it as bad as spectator mode? Well no it is not but its still making me feel ill.

    If spectator mode in first person is 100% microstutter then right now i see about 25% of that.Still enough to make gaming on chivalry strain the eyes.


Log in to reply
 

Looks like your connection to Torn Banner Forums was lost, please wait while we try to reconnect.