No one plays TO/classic at my ping any more



  • It’s only FFA, LTS or TDM servers that are populated. It’s quite sad. It’s very frustrating having to play with 90-120+ ping servers for TO and classic.

    Hopefully it’s only the server browser making them un-populated…


  • Global Moderator

    And where about is your area?



  • It’s an overall problem. Game is moments past dead.
    Hardly any newcomers and the game is stuck with the same population who will eventually all leave since they want improvements and this game doesn’t get any.
    Focus your attention on other games. Just saying.



  • I play on center Europe servers and they are starting to suck badly. Most of the players play on classic servers that I do not like, it is nearly impossible to play between 10-15 am on workdays and Multiplay servers tend to lag. The devs need to do something to bring more players. More TO maps would be an excellent start.



  • Aren’t you east coast mithron? I find the opposite of what you are saying, maybe its your playtime, but sI’m west coast and all I ever find is populated east coast servers, including TO. I’ve played with 80+ ping almost all my chivalry time as there really isn’t any west coast competitive matches so I’ve made sure I’m used to it, but still even when I’m alone and want to play a west coast server I find way more populated east servers.



  • Weird, yeah I’m east coast. I usually check between 7 pm - 12 am EST. and I’m only finding 90-120+ ping servers. The 30-60 ping servers are only FFA, LTS or TDM for me during those times. :(



  • @SOC:

    Weird, yeah I’m east coast. I usually check between 7 pm - 12 am EST. and I’m only finding 90-120+ ping servers. The 30-60 ping servers are only FFA, LTS or TDM for me during those times. :(

    Use the alternate server browser because the TO are not always “really” full. There are usually several active Official TO servers, I play on them all the time (Illinois, I get 50-70 ping on them from Toronto). More private TO servers too.


Log in to reply
 

Looks like your connection to Torn Banner Forums was lost, please wait while we try to reconnect.