Server list not refreshing



  • Here’s an interesting one…

    Played just fine yesterday. Tried to play today, and my server browser will not refresh at all.

    What the hell? Nothing has changed since yesterday. I haven’t even restarted my computer since last playing.



  • I was going to start a thread, but I am having a similar problem. I was playing last night with no problem, but today when I go into the browser I don’t find any servers. My internet connection is fine. I tried rebooting to see if that would help, but it didn’t. I am not opted in to the Beta.



  • Same thing just happened to me, I was in a match and it just lagged massively and booted me out. Now my server list isn’t doing anything at all. Tried taking off all the filters and hitting apply as well as checking my internet and rebooting.

    Edit: Can’t even go into training, game just crashes.
    Editx2: Whoops, didn’t see the pinned thread about this. I beg fo’givahness.
    Editx3: Followed the instructions and everything’s working now.



  • unbeleivable



  • Ok, mine is working now. When I was having the connection problems it said ‘no connection’ at the bottom of Steam even though I was connected to the net just fine. The ‘no connection’ disappeared and when I went back into Chivalry it worked normally. Not sure if the two are related or if it was just a coincidence.



  • @Sir:

    Ok, mine is working now. When I was having the connection problems it said ‘no connection’ at the bottom of Steam even though I was connected to the net just fine. The ‘no connection’ disappeared and when I went back into Chivalry it worked normally. Not sure if the two are related or if it was just a coincidence.

    Related, that would do it.



  • Yep, unfortunately it’s a steam thing :( So when steam goes down while you’re in game, these lovely issues occur. I can’t even join any server if steam goes down right as I’m loading the game :(