Chivalry Crashes NVIDIA GeForce GTX 560



  • I have purchased Chivalry: Medieval Warfare from Steam several months ago, and this problem has persisted relentlessly, regardless of any and all attempts to fix it on my own.

    The exact nature of the problem is that after textures initially do not load a period of 30 seconds of black screen occurs after which the game then plays perfectly.
    This however is short lived as the game will without fail periodically crash my GeForce GTX 560 every 5-7 minutes, forcing me to restart my PC.

    I have already tried a range of fixes for this issue such as updating graphics drivers, UN-installing and reinstalling Chivalry, verifying the integrity of the game cache, changing graphics settings and quality within Chivalry all to no avail.

    I have waited patiently in hope of an game update from chivalry to fix this issue however if there has been one it has had no effect.

    This is a frustrating situation as I have not been able to play even one full MP match let alone be allowed to finish the tutorial.

    Any advice on how to fix this problem would be much appreciated.

    Thank you

    OS: Windows 7
    Graphics Card: NVIDIA GeForce GTX 560



  • Please attach your Launch.log, DxDiag.txt and latest crash .dmp file in a reply here.
    Launch.log is found here: Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs
    DxDiag.txt is generated by clicking the Windows Start Menu, typing dxdiag into the search field, selecting dxdiag.exe from the search results, and then clicking the Save All Information button in the dxdiag app.
    The crash .dmp files are located in the same location as the Launch.log.

    Text stolen from ReMixx

    Based on the symptoms, it sounds like an issue with something else on your computer. Is the 560 overheating?



  • I hope those are sufficient.

    As for my graphics card overheating, I have no idea, all I know is that chivalry is the only game out of my 47 which has ever encountered problems of this nature, I have run much more demanding games on full graphics (Metro 2033, Arma 2, ect…) with no such issues.



  • Those aren’t ‘more demanding games’. Chiv isn’t exactly the best optimized UDK program.
    Regardless, the 560 with that processor should run very well and you have the latest video drivers.

    Maybe your computer is using the Intel graphics instead of the video card?
    http://superuser.com/questions/231446/how-to-use-dedicated-video-card-instead-of-onboard

    Otherwise, what makes you say it’s the videocard crashing (as opposed to the UDK crashing)?

    If it were me, I’d nuke it from orbit. 1) Uninstall the game using Windows control panel, 2) Delete the Documents/My Games/Chivalry folder, 3) Restart computer and do fresh Chiv install through Steam.



  • Well First off when it crashes I lose all connection with my monitor, it rejesters as the power is lost even though my PC is still on, and the graphics card goes silent, like dead and the only solution is to hold the power button for restart. Secondly occasionally I will get messages informing me that my graphics card crashed. Though the symptoms are always consistent this message is not.

    I will attempt to nuke it in the mean time to see if this has any effect.



  • Nuking had no effect unfortunately. Though I have installed SpeedFan to see if in fact my card has been overheating, but it seems to sit stable at 65C, so I find it unlikely that it has been crashing due to overheating.

    I have been scourging through the log files to see if any interesting bits of information stand out, unfortunately what i have found i could make little sense of, perhaps if I attach them someone might gleam some wisdom from them?



  • Windows environments are all different, so it’s difficult to diagnose the issue from a BB.

    It could be a software conflict. I am not even going to wade into that, other than to say you should try a minimal startup and see what happens.

    The behavior you describe makes me think this could be hardware related - a bad spot on a memory stick that doesn’t get used often, a problem with the second core in the CPU, maybe a hard drive issue. Try running memtest86, the Intel Processor Diagnostic tool and disk check.
    http://www.memtest86.com
    https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=19792

    In the meantime, perhaps someone who can read the log file will chime in?



  • My system passed the Intel Processor Diagnostic tool and disk check, I do not however understand how to use memtest86, the link leads me to a rather vague description of what I am required to do to access its features.

    The information is clearly formated in a way that those with computer knowledge will understand, which I alas lack.



  • http://www.memtest86.com/downloads/memtest86-iso.zip

    1. Download the zip file to your desktop
    2. Right-click on the file (after download) to expand, again to the desktop.
    3. Delete the zip file, keep the iso
    4. Open whatever CD burning software program is on your computer.
    5. You’ll have to figure out how to make it make a CD from an ‘image file’. That file is the iso on your desktop. Hopefully you have a burnable disk. If not, there is a line on the downloads page for using a flash drive.
    6. Once the CD is done, turn off your computer.
    7. WIth the CD in the tray, boot your computer. Press a button when it says “Press any key to start from CD”
    8. Let memtest run at least 5 times.

    The Intel processor test should be run for at least 4 hours to be sure it is accurate. - may want to do that again.

    And again, this is just a hunch. Could be totally wrong.

    Perhaps someone who can read the log file will chime in?



  • still having problems with the memtest, got in on the cd now but I never have any options to boot anything from cd, unless maybe I go into the BIOS menus.

    I ran the intel processor check, it says the estimated time is still 4 mins, and it passed again.


  • Developer

    Windows 7 has a built-in memory diagnostic that can catch a lot of RAM issues. Not as many as memtest86, mind you. Open the start menu, search for ‘memory diagnostic’, it should come up.

    This doesn’t sound like a RAM issue though nor CPU issue, what with the video card going dead. It sounds like a video card issue, or possibly something like a PSU problem. You can try a GPU burn-in tool like MSI Kombustor or Furmark or something (run them in burn-in / stress test mode, not a time-limited benchmark).



  • The Windows memory diagnostic passed, and running Kombustor at all levels and all stress test modes flawlessly (except physX which had frame rate lag while GPU temp did not exceed 65C) All other tests leveled out at 80/81C after around 20000 frames.

    After talking with some friends who understand the tech better then me, I am myself starting to question weather the crashes are related to the graphics card, rather then the crash effecting other core components and through that cutting power or disabling the card?

    Once again It would be helpful if some one who could read log files pitched in.



  • @RX132:

    I am myself starting to question weather the crashes are related to the graphics card, rather then the crash effecting other core components and through that cutting power or disabling the card?

    Yes - the ‘fun’ of troubleshooting Windows is that it’s all interconnected - so something wrong here can show up over there. It’s also important to make sure you know what works so all of these tests ARE getting us somewhere, I swear! :)

    You might try opening up the case and removing the graphics card, then re-seat the card.
    Check the power connections. Feel free to unplug and reseat every cord in the case.
    Wouldn’t hurt to re-seat the memory chips as well.
    And I bet you could use a few squirts of canned air in there, amirite?

    A faulty power supply unit (PSU) can cause weird things and also damage your components before finally dying. SImilarly - a power supply that isn’t strong enough for your components may boot Windows and run some games fine, but fail when put under a full load.
    That certainly could be a problem, but a tough one to diagnose unless you can use a multimeter (or buy special tools). Best to just hope you find a loose plug when you open your case. :(

    Just out of curiosity, what is the make/model/and maximum power output of your PSU?



  • Unfortunately I have a of lack some of the basic tools that would make me uncomfortable taking apart my PC and really getting in there rather then just taking apart the case (grounding cables and such)

    I am sure that the PSU is in an ATX configuration, Actually the manual describes it simply as Standard ATX PS2 and nothing else, im not sure where i would get more detailed information.



  • So, Having thought about this from a slightly different perspective, is it possible that this is somehow udk.exe realted? maybe the udk.exe crashes and causes some deeper error? (Im running out of ideas)



  • While the game isn’t very well optimized, there’s no reason it should cause a problem with your computer. Most likely it is revealing a deeper problem (rather than creating one).
    I mean, from your specs, there’s no reason you should have a problem with this game. So there has to be something happening that is unique to your system.

    If possible, borrow a graphics card from a friend. If his card works fine for you then you know your card has the problem. I’m not sure what other advice to offer. Diagnostics you tried don’t indicate a problem. The steps I would try from here would require additional parts and working inside the case.

    Would be nice if someone who could read the log would comment.



  • I am experiencing the exact same problems as RX132. I have run all the same diagnostics with no problems detected. I am using a GTX 570 and running Windows 7.


Log in to reply