Settings not saving



  • I am really enjoying the game but also having issues with my video and key settings not being saved, so chivalry opens in the wrong aspect ratio as well as not in fullscreen every time which is quite annoying but something I could live with. On top of this though my binds are also not saving which is a huge pain in the but for someone who prefers EDSF to WSAD as it takes me a couple minutes to go through all the keys and completely remap them every time I open the game. Does anyone have any idea on why this is or how I can fix it? I have been looking in the game files for a specific config file which i could possibly manually change these settings or something on but I cannot find the right one as there are many. Also yes I am clicking the save/finish buttons in the bottom right when I modify these settings. They save for that session but as soon as I open the game back up its like I have never played before.

    Thanks in advance for any replies.

    EDIT: I think I managed to find the Config files responsible for these settings named UDKSystemSettings.ini and UDKInput.ini in the Chivalry config folder however manually modifying the inputs for the bindings and fullscreen/resolution I desire has had no effects. Although these files remain altered when I open up Chivalry I am stuck again with 19**x1080 and default binds. How is this possible? Is it perhaps because I have steam installed on my SSD but the game on my storage HD? Any help is much appreciated as this is gonna drive me crazy.



  • You could try to modify the UDKInput.ini file and change your keybinds in that and save it.



  • Looking back in the forums I also found this post :

    http://www.chivalrythegame.com/forums/viewtopic.php?f=69&t=12552

    This leads me to believe that I am possibly editing the wrong files but I cannot seem to find any other on my computer. In that post it makes it sound like there is a separate folder for the game than the one related to steam but this is not the case for me. When I downloaded it from steam it asked me where to install and I chose my hard drive which is separate from where steam is located. I have been modifying the files on : Computer > Terradrive > Games > SteamApps > common > Chivalrymedievalwarfare > UDKGame > Config

    Is this the right directory? Sorry for droning on forever I am just obviously thoroughly confused as to why this is happening. Thanks again.



  • That’s the folder, then go to the UserInput.ini and find

    Bindings=(Name=“A”,Command=“GBA_AOCLeft”,Flag=“KBFlag_Movement”,FriendlyName=“MoveLeft”)
    Bindings=(Name=“D”,Command=“GBA_AOCRight”,Flag=“KBFlag_Movement”,FriendlyName=“MoveRight”)
    Bindings=(Name=“W”,Command=“GBA_MoveForward”,Flag=“KBFlag_Movement”,FriendlyName=“MoveForward”)
    Bindings=(Name=“S”,Command=“GBA_Backward”,Flag=“KBFlag_Movement”,FriendlyName=“MoveBackward”)



  • @Keith:

    That’s the folder, then go to the UserInput.ini and find

    Bindings=(Name=“A”,Command=“GBA_AOCLeft”,Flag=“KBFlag_Movement”,FriendlyName=“MoveLeft”)
    Bindings=(Name=“D”,Command=“GBA_AOCRight”,Flag=“KBFlag_Movement”,FriendlyName=“MoveRight”)
    Bindings=(Name=“W”,Command=“GBA_MoveForward”,Flag=“KBFlag_Movement”,FriendlyName=“MoveForward”)
    Bindings=(Name=“S”,Command=“GBA_Backward”,Flag=“KBFlag_Movement”,FriendlyName=“MoveBackward”)

    Yeah those are the lines that I modified for EDSF as well as several other binds but it is still not doing anything. They are saving and when I open it up again it still reads EDSF but when I open my game they are all just default. I am not quite sure exactly how this is possible and I am completely out of ideas… might just try uninstalling and redownloading or something unless someone can offer some insight. Thanks.



  • Also try editing the UDKGame.ini, DefaultInput.ini and the DefaultSettings.ini files.



  • @Keith:

    Also try editing the UDKGame.ini, DefaultInput.ini and the DefaultSettings.ini files.

    Thanks for your reply, that was exactly what I needed to do. After altering the default input/system configs I was able to permanently change them and it now opens fullscreen with the right binds. Although it still loads the wrong aspect ratio simply saying 1080 hd (this looks like crap) which it considers 19**v1080, that was an issue I was having with other games too before I enabled the GPU scaling function for my card so it could possibly be related to that or just me not knowing exactly what to modify within the config. I could possibly mess with some of the options other than changing the rez numbers from x 1360 and y 768 (especially if someone knows a specific parameter I could change to alter the load aspect ratio) I may just leave it at how it is because simply having to change the resolution every start up is not a huge deal.

    Once again thanks for you help Keith.



  • You’re welcome. If you need anymore help, feel free to post or send me PM. :)


Log in to reply