The game isn't starting



  • Hey all!
    I know this has been posted a lot but none of the threads helped me.
    I just installed chivalry via DVD (didn’t buy it on steam).
    Steam updated it and everything looked fine. But it didn’t ask me to enter the key somehow.
    And I can’t start the game. When I do it shows a picture of chivalry and then a new window opens. It says: 32-bit, DX-9. And then… nothing… I close the window and it tells me that the UDK.exe is not working.

    And steam always says: 1 Days left. I have a legal copy of the game! Why can’t I enter that key? It just didn’t ask me!
    I made sure to follow each step of the installationinstructions. But it still doesn’t work.
    I’m also wondering what that 32-bit means. Is the 32-bit version of the game installed or what? I have Windows 7 Ultimate 64bit. Is that the problem?

    Please help me!

    Regards,
    Peter van Parodin



  • So here’s my DxDiag file. I couldn’t find that launchlog or whatever. There is now “log” folder at all in the gamefolder :(
    [attachment=0:jkwgp6wp]DxDiag.txt[/attachment:jkwgp6wp]



  • There could be a number of reasons behind this so I’m going to help you go over each possible solution.

    Right now, go to the game in the Steam library, right click on it then go to properties then go to launch options and put in:

    \dx11

    Come back and tell me if that works.



  • First I want to thank you for helping me! :)

    I did what you said and this was what happened:
    [attachment=0:1in7zrsq]Bild1.jpg[/attachment:1in7zrsq]
    I clicked on “Ok” and the old problem was there again… UDK.exe stopped working :(
    I have also updated my drivers. So I guess retarded drivers shouldn’t be a thread…



  • Try adding this instead:

    -dxlevel 90



  • didn’t solve the problem.

    I hope I won’t take too much of your time ;)



  • @Peter:

    didn’t solve the problem.

    I hope I won’t take too much of your time ;)

    Nonsense, no such thing as too much time. :) I just hope you have the time for us to go over any possible solution to help you get the game started.

    This solution comes from one of the moderators here:

    The usual solution to this (and I hope that it works for you) is to going to C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\RedistChiv in Windows Explorer. Run the two vcredist executable files. Then go into DXRedistCutdown and run DXSETUP.exe.



  • Well don’t worry about that. I have the time and of course I want the game to work so I won’t give up that early ;) I wanted this game so bad so I have my motivation XD

    Well I followed the path, but I don’t find any vcredist executable files over there. There’s just a Folder named “AMD”

    But I found some vcredist files in another path. …/chivalrymedievalwarfare/_CommonRedist/vcredist/2010
    there are two vcedist files: vcredist_x64 and vcredist_x86
    should I run them?



  • Yes, give it a go, then after go into DXRedistCutdown and run DXSETUP.exe.



  • OK I did what you said. The game is still not starting up, but at least there is a little change.
    When moving the cursor into the window of the game, the cursor doesn’t disapear anymore. It shows the “loading-icon” (you know the blue ring in windows 7)

    But nothing else changed.

    But when using the two vcredist files, it asked me weather I want to uninstall something or to set it back to it’s earliest state. (sorry my english isn’t perfect so I don’t know if I described this correctly)
    I chose not to uninstall but to reset. Did I right or should I have chosen uninstall?



  • Do it again and this time try uninstall, then reinstall Direct X.



  • did it. nothing changed.





  • ok I’m trying. I guess I’ll need some time reading all.

    But in the meantime I have a question: Can you enter the serial key of an already installed game? Steam didn’t ask me to enter the key during the installation.

    EDIT: Alright I just went through all possible solutions (some of them are useless for chivalry as it is not an old game and my PC is not the newest thing)

    None of them worked.



  • @Peter:

    ok I’m trying. I guess I’ll need some time reading all.

    But in the meantime I have a question: Can you enter the serial key of an already installed game? Steam didn’t ask me to enter the key during the installation.

    EDIT: Alright I just went through all possible solutions (some of them are useless for chivalry as it is not an old game and my PC is not the newest thing)

    None of them worked.

    If you have the DVD, I don’t think that this game requires the Steam key when using the disc.

    Hm…Try reinstalling and updating your graphics drivers and reinstall DX unless you already have.



  • I already have done that.
    Well but I think it does.
    Steam says “1 day left” as if I would be making use of a free weekend. But I installed it per DVD.
    Well I guess I’ll have to try another reinstall unless you have another idea



  • @Peter:

    I already have done that.
    Well but I think it does.
    Steam says “1 day left” as if I would be making use of a free weekend. But I installed it per DVD.
    Well I guess I’ll have to try another reinstall unless you have another idea

    I guess you’ll have to wait until the developers provide a solution. I apologize. :(



  • You’ve tried your best to help me and I’m very grateful! It’s not your fault that any game that needs steam has problems on my computer. (I have 3 Games on steam and they have all problems. but this is the biggest one)
    I want to thank you again for your help even though it didn’t solve the problem.
    When I finished reinstalling I’ll try the things you told me again and hope it’ll work.



  • I hope it works for you. Chivalry is a really fun game, that right now is unfortunately affected by Steam issues. I wish you luck. :D



  • Yeah, it looks like steam is doing something wrong… I’m also wondering why I have different paths in the gamefolder. I’ll try to find the launchlog somewhere.

    EDIT:
    http://www.youtube.com/watch?v=VzXGle–pBU
    I looked into this video.
    I dont even have that launcher in my folder!! Something is really going wrong here O.o


Log in to reply