[FIX] Please wait while the game loads…



  • Hi. I´m one of the unfortunate ppl trying to play on the free weekend without success. After a long research for an answer and trying desperately to make this game work i think i finally got a solution.

    The problem lies on your computer or router firewall. Idk exacly why the game needs an open channel in your computer but it needs. At least for the majority of the servers but anyway, like most games, the router deals everything using uPnP, which opens and forwards the network traffic for your application automatically, but for some unknown reason this game does not seems to work well with this protocol.

    Here´s a few things you can try to prove this is the problem. I´m sorry but i wont get into details how this can be done, you must google the answer if you dont how to do it for your router model.

    1. Activate DMZ on your router and set your computer IP manually to the same IP you setup on the router. By placing your computer to the DMZ it will be automatically out of the firewall. Any contact from the external side will be forwarded automatically to your computer.

    2. On windows firewall, look for “Allow an app or feature through windows firewall”. Find chilvary on the list and make sure both private and public checkboxes are active. You can also disable windows firewall just to make sure but remember to have it enabled later.

    Thats it! Worked for me and a few friends and based on what i read so far from logs and debug messages, this is what is causing the problem. Probably theres nothing to do with steam or the free weekend. it is just a cheap excuse.


Log in to reply