No server, and no weapon xp.



  • Hi
    I’ve just bought the game, instal, and I don’t see any server !

    I’ve tried this : viewtopic.php?f=69&t=2075

    this : viewtopic.php?f=69&t=3900

    and this : viewtopic.php?f=69&t=10664. With this alternative brower, this is what I’ve got :
    Refreshing servers…
    Retrieved list of servers.
    Querying individual servers…
    Retrieved 0 servers with 0 players playing.

    I’m running on win 8 pro 64bit. I’ve also tried on seven 64bit, same problem. I Have no Firewall. Please help me.

    I can play multiplayer when a steam friend invite me. In game, my weapon xp reset after each game !.

    22€ for not working game, it’s too expensive !.



  • No support ? :/



  • Hello,

    Please make sure you are not opted into the beta.

    Right click Chivalry in your steam games library. Click on properties, then click on betas and then make sure it’s on NONE-Opt out of all beta programs.

    Since you can’t view any servers in our browser AND the alternate browser, that’s the only thing I can think of why you’d have this issue.



  • Hi,

    Thanks you for this answer, but I don’t play in Beta :/.



  • Did you try all of these? Also try running as an administrator. You can’t seem to ping any of those servers.

    Server Issues:

    Server issues are related to Steam. These are possible solutions that create a work around.

    Solution 1: If you are getting high ping, make sure to join a server that has low ping.

    Solution 2: Deleting your C:\Program Files (x86)\Steam\config\MasterServer2.vdf to force Steam to regenerate it may help.

    Solution 3: Make sure you are running the main game and not the beta. You’d be surprised how many people make this error.

    Solution 4: Go into Steam. Click on Steam > Settings> Beta participation > Change > Steam Beta Update. Set this to join for the beta. Restart Steam. Run Chivalry Medieval Warfare and go into the Server Browser. Restart the game and try again.

    Solution 5: Try Remixx’s wonderful alternate server browser here.

    Solution 6: Your router may not be able to handle the sheer quantity of connections that Steamworks is creating to query servers. In Steam, click Steam -> Settings -> Downloads+Cloud. Change the “Game server browser: max pings / minute” setting to something lower.

    Solution 7: If you just left a server and now can’t find anymore servers, hit the refresh button. If that does not work, close the game and restart Steam.

    Solution 8: View Steam’s guide for Troubleshooting Network problems. Look here.

    Solution 9: Restart Steam. I know I’ve mentioned this already but it could be Steam causing problems so it’s always a safe bet to restart it just to make sure.

    Solution 10: Create a game with bots, play for a bit then try joining a different server.

    Solution 11: Try rerunning the redist in C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Redist\UE3Redist.exe

    Solution 12: You may have a software firewall, hardware firewall, security software, or some other software or hardware interfering with Steamworks’ ability to list servers. Please try without any firewalls if possible, and if you have your own router try bypassing it and connecting to your ISP’s internet connection directly.

    Solution 13: Click Start button and cut and paste this into your run dialog box, “C:\Users%USERNAME%\Documents\my games\Chivalry Medieval Warfare\UDKGame” and hit enter
    ** If the above doesn’t work, try this: “%USERPROFILE%\Documents\my games\Chivalry Medieval Warfare\UDKGame” ** You will see a “Config” folder. Rename it to “Config.old” Start Chivalry and see if the server list is working now.

    Solution 14: There is a bug that prevents you to join friends using Steam if you already have the game running. So close the game, find your friend on the list, click join game and it shall load the game and server for you.

    Solution 15: On Windows firewall, look for “Allow an app or feature through windows firewall”. Find Chilvary on the list and make sure both private and public check boxes are active. You can also disable windows firewall just to make sure but remember to have it enabled later.

    Solution 16: The server itself could need updating so you’ll have to wait for the server owner to update the server.



  • Hi

    Thanks you for this answer. I’m in my brother’s house, with my computer, and the server browser works fine. I think the problem is my router, I will contact Netgear in a few days.



  • Problem solved by updating my routeur firmware.


Log in to reply