Microphone issue



  • It seems like chivalry is somehow blocking my mic as soon as I start it. I’m not talking only about ingame-voice. I’m usually playing while being on a TS3-server and it blocks all voice-transmission.

    To “solve” the problem (for a short period of time) I have to minimize the game, go to windows system control–> sound–>recording devices and then deactivate the mic and activate it again.
    That does only help sometimes though, it is also possible that it blocks the mic as soon as I maximize the game again to continue playing.

    My headset is a Gamecom 777 and is plugged in its own little soundcard. Then you plug the soundcard in a USB-port of the pc.

    Other system specs, in case that they are needed:
    Windows 7 64bit
    4 GB RAM
    Intel Core 2 Duo E8400 @3.00GHz
    Nvidia Geforce GTS 250

    Maybe somebody has already encountered and solved the same or a similiar problem, allthough I could not find any fitting topics in the forum.

    I’d appreciate any help.

    Regards
    Hudson



  • Try TS3 as an Administrator, this is an odd problem that may be solved by simple things like this.



  • I had his problem with several games at one stage when I updated my TS3 a couple of years ago. Running it as admin did fix the problem for some odd reason.

    Though the in game voice is pretty crap. You can never hear anyone clearly if at all.



  • Than you for your replies.

    I’ll try it and let you know if it worked for me too.



  • Unfortunately the problem still occurs, help is still needed.

    It also seems to occur while playing Chivalry only, I have not encountered the problem in another game yet.



  • Try turning off the in-game voice chat.



  • Try not using the overlay. I have heard of that causing problems too.



  • @Space:

    Unfortunately the problem still occurs, help is still needed.

    It also seems to occur while playing Chivalry only, I have not encountered the problem in another game yet.

    Yeah my problem was with all the games I use team speak for. So its a bit different. And this was before chivalry was released.



  • @Keith:

    Try turning off the in-game voice chat.

    Seems like that solved the problem. At least it did not occur the last time I played.

    Thank you, my lord.



  • @Space:

    @Keith:

    Try turning off the in-game voice chat.

    Seems like that solved the problem. At least it did not occur the last time I played.

    Thank you, my lord.

    Well I was too hasty with my post. It still happens. While I am playing other games, such as Arma 3, it does not happen.


Log in to reply