[SOLVED] Shield block cancels



  • Half of the times I start up Chivalry and take a class with a shield, the shield will twitch when I try to block. Meaning the block will cancel randomly. I have tried testing this extensively, with full stamina, half stamina, if it happens while running or standing, after an attack, if I have MaA or Knight class, which shield I pick, etcetera. And it happens regardless of those factors. I don’t think there is anything wrong with my right mouse button as it registers perfectly on any other game where you have to hold it, and normal parry also works fine. Neither do I have connection issues, but I have noticed that it will occur more often when the server is being laggy, so it might have something to do with that.

    What I want to know is if this is a bug or is just caused by lag, if it is either of those I assume other players will also have this problem.



  • I have this problem too, but I thought there was a reason it wasn’t staying up, either I got hit and knocked out of the block and need to reclick it, or having low FPS. I don’t use the shield a lot, I think mostly because in fights I found it not up the way I wanted.

    But yeah I thought I was the only one who had problems with this, but I guess when I hold right click down I expect the game to keep my shield up as much as possible. EG even if a kick knocks me out of the block and I am still holding RMB, it should come up automatically as soon as possible.



  • I have the same problem. It’s definitively an issue with the game.



  • @Scorp:

    If your issue is not seen to or status is not updated within a large period of time, feel free to bump the thread or PM myself.

    Bump :D



  • It’s a bug we know about probably due to lag. We’ll look into it.



  • Thanks for the reply, good to know it has been noticed.



  • Well, with the latest patch, this issue has been fixed, or at least for me. Dunno what has been done, but I can now finally block without spazzing. So thanks for fixing.


Log in to reply