Heavy lag and FPS drop with USB Headset



  • Hello guys, my hardware and network are normally more than capable of handling this game and normally I see 60-75 FPS. But whenever I plug in my usb headset, the game starts to drop fps and lag, making it unplayable.

    I have attached my DxDiag.txt.

    Edit: I’ve solved the “lag” issue by applying this solution:

    “Solution 7: In the UDKSystemSettings.ini, change the OneFrameThreadLag section from True to False.”

    BUT there is still a huge FPS drop, making it about 15-20 fps.

    BTW, there is no driver for the headset and I’ve already tried to uninstall and install it again but it didn’t work. Also, there aren’t any problems with any other games.



  • My guess is your headset is causing an issue where it is taxing your CPU for some reason or another. Perhaps poor drivers or there is a setting somewhere telling it to user super mega sound quality extreme.



  • @Toll:

    My guess is your headset is causing an issue where it is taxing your CPU for some reason or another. Perhaps poor drivers or there is a setting somewhere telling it to user super mega sound quality extreme.

    I thought as well but I tried some CPU intensive games like BF3 but the issue doesn’t show itself with these games. It happens only in Chivalry. There is a new update though, I will try it.



  • Try this:

    In Speaker Properties (windows) for your USB headset
    Check your sampling rate, your dxdiag says it is minimum of 100.
    Try set it to 16bit, 44100hz.

    Let us know how that went.


Log in to reply