Problems with materials.



  • Hello, I work on a map and I have a problem since today.

    When I tested the game (launchgame sdkcontent), some materials are not displayed, instead I had the white / blue checkered. I’ve had this bug when I was working on my first map, I just replace materials that are not displayed by other things like static mesh. But this time I can not do the same because it is the lava, there is only one material for the lava!

    I tried to remove the lava to get water: it works.
    Then I remove the water and gives the lava: This again it does not work.

    I tested everything, buildsn cook etc… it changes nothing!

    The strangest thing is that the materials are displayed very well in the SDK, it’s just in-game it does not work :(

    I did test all week on my map, the material lava functioned properly, I really do not understand …

    I hope you understand me, I use a translator!

    Thank you in advance!



  • Nobody has a solution? I feel I have lost a week of work … :(



  • I think it may be an issue with cooked maps and packages/materials. It may be addressed at a later date when the SDK gets out of alpha.



  • I think its those agathians. Painting everything in their colours.


  • Developer

    PMing


  • Developer

    You’re using a Fluid Surface Actor. We don’t use those anywhere, and the artists are telling me you shouldn’t use it because it’s “gorpy” or something. Try using a Static Mesh Actor instead (search for a “plane” static mesh in the content browser). I tried one in your level and it works.

    You could also open AOCTO-Citadel_p and look at how we do the lava in there.


Log in to reply