Ping display in the server browser



  • First off, I am not talking about non-official servers, I know you can’t do anything about them.
    My problem is mainly with the server browser. I search for a server and get some displayed with a range of 15-60 ping, which should be perfectly fine. But when I join those servers, they lag like hell sometimes, so bad that you can’t even parry.
    And no, my connection is perfectly fine, I have a very solid internet provider and I don’t try to join servers on another continent. I live in germany and the problem is with DE/UK servers, too.
    I am wondering if only I have that, because I see noone else complaining about it.
    And no, the alternate server browser also does not work for me:
    viewtopic.php?f=69&t=10664&start=140#p149263

    Here is some footage(mind that the freeze is not even the core issue which I am talking about, it’s the lag that makes the knights axe go through me and my following stab not connect):
    kPaEZywhJ3g
    from this server:
    [image:1jjtmmj5]http://imageshack.us/a/img560/6219/i3b.png[/image:1jjtmmj5]
    The ping on the selected one says 58, but this forum got some issues with pictures.

    Does this happen to you guy too? Can you give me any tips?



  • Yeah… thanks for the overwhelming response.
    Is there any actual Technical support that I can refer to?



  • Does this lag affect everyone in the server or only you?



  • @rumpelstiltskin:

    Does this lag affect everyone in the server or only you?

    If you ask on a server if it lags you will always have some people it does even if it does not. I don’t know how I am supposed to find out.



  • @Atanar:

    @rumpelstiltskin:

    Does this lag affect everyone in the server or only you?

    If you ask on a server if it lags you will always have some people it does even if it does not. I don’t know how I am supposed to find out.

    Thats not true, just ask “Wer sonst hinken oder ist es nur mir?”

    Sometimes official servers do lag, and it is usually pretty obvious and has nothing to do with ping but affects everyone. Server disk or network activity got overloaded.

    I went through a short period of lagging and identified my wireless connection as the issue.

    Anyway you have to find out if it is you or everyone, until then its hard to pick a direction to help.


Log in to reply