Javelin Archer: Switching Weapons



  • I posted this in the bug reports forum and it seems to get no replies and I’m unsure about how to delete topics posted…so I’m giving it a shot here and hopefully someone will read and give me positive feedback:

    Hey guys, before the patch I recently got into playing with a Javelin Archer and I’ve actually become pretty decent. However, after the recent patch, I cannot cycle through my weapons like I use to. I don’t use KB+M, I use a gamepad(360 controller) and my ‘Y’ button cycles through my weapons normally with every other class and I like it that way, except Javelin Archer. With the Javelin Archer, I get stuck in the throw jav phase. Before the patch, you could cycle to that phase and back out of it straight to your Secondary Weapon, but now I literally cannot change weapons. I understand(sort of) the cause for this, but I also do not understand why the throw phase is considered a different weapon and you can “weapon switch” to that phase. Please revert this back to the way it was or remove being able to swap to that phase, it’s pretty irritating since I don’t use the 1, 2 and 3 keys to switch my weapons. Any input/insight to why it is like this is acceptable and appreciated. Thanks! :D

    ps. Please no negativity. I’m not looking to argue or debate KB+M vs Gamepad here.



  • Hey! Sorry if this is super late. I’m new to using the controller but really enjoy it so far. My solution for switching weapons has been using the D pad. left = 1, up = 2, right = 3, and down = 4

    An odd problem I’ve been having is that every once in a while my guy will just randomly switch weapons (which can be real inconvenient!) but it is not often enough to see as a pattern…



  • @Roborgar:

    Hey! Sorry if this is super late. I’m new to using the controller but really enjoy it so far. My solution for switching weapons has been using the D pad. left = 1, up = 2, right = 3, and down = 4

    An odd problem I’ve been having is that every once in a while my guy will just randomly switch weapons (which can be real inconvenient!) but it is not often enough to see as a pattern…

    Thanks for the reply! Late or not, it IS appreciated. I actually started doing this myself, except my crouch button toggled with down on the d-pad and to stand I hit up on the D-pad(cannot seem to change this either…I’m not good with ini editing.) I had actually set it to ‘Right D-pad’ and it would take my crosshair away, along with switching weapons… So I quickly ditched the settings. If you know any way to edit the ini I’d appreciate it. I’m a bit weary of changing the D-pad settings too because I occasionally hit something on it by accident… lol. Thank you for caring enough to reply, I’ve posted several times and never got any good answer. Thanks.


Log in to reply