Mouse "Stair Step" Issue



  • Hello. This is an issue I haven’t encountered since the days of WinXP where I could never get mouse acceleration turned off and it interfered with GoldSrc engines. Well, a similar problem has arised with a couple a games now, though it likely isn’t the same problem.

    D3UEXRiHCgI

    As you can see, when moving diagnolly, the mouse “stair steps.” It sort of stutters, and this stutter can even occur with horizontal and vertical movement. The problem is exacerbated with low FPS; the lower the FPS, the worse the performance.

    Curiously, this only started occuring when I switched to Windows 7 64-bit, and never occured when I used Windows XP 32-bit. I still don’t know why it happens, but I suppose that’s why this thread was made.

    This also occurs in Natural Selection 2; pretty much the exact same problem. But I don’t think it’s mouse acceleration being turned on somehow.

    Information:
    Windows 7 64-bit Ultimate Edition
    Radeon HD 4890 1gb
    Intel Core 2 Duo 3.16 Ghz
    4gb ram

    The mouse in question is a Logitech G700, that functioned perfectly on Windows XP. It’s set to 1200 DPI. Changing DPI has no effect.

    This isn’t a performance issue. This mouse functions perfectly in any other game except for Chivalry and Natural Selection 2, and my computer can run either game decently well at low settings. Curiously, this does not occur in other UE3 games, such as Red Orchestra 2.

    What I’ve tried:
    Disabling mouse acceleration everywhere (yes, including ViewAccel lines in Chivalry’s .cfg files).
    Disabling mouse accel at the OS level (using registry tweaks)
    Disabling “Use OS Drivers for speed and acceleration” (this is a given)
    Changing DPI
    Reinstalling mouse drivers
    Reinstalling LGS/Setpoint (I prefer to use SetPoint)
    Using the mouse on wired mode
    Using the mouse on wireless mode
    Disabling Chivalry’s Mouse Smoothing (also a given)
    Disabling VSync
    Changing “MaxDesiredFrameRate” (or whatever it was) to 120
    Probably other things I can’t recall

    What I’ve managed:
    Lowering polling rate to 125 Hz from 1000hz. This mitigated the problem, but the problem still exists. Ideally I’d like to eliminate this problem so I can make use of 1000Hz polling rate, as this was doable in Windows XP. Downgrading OSes or changing mice are not options.

    I’d really love it if anyone could shed any amount of information on this. If not, maybe someone with a similar problem can try what I’ve tried and it could work for them. Thanks in advance!


Log in to reply