Connection to host timed out



  • My friend set up his own server today and six of my other friends can join it without any problems but every time I try I just get “Please wait while the game loads…” and after a few minutes “Your connection to the host has been lost” I’ve tried EVERYTHING I could find online pertaining to this problem and how to fix it and NOTHING has worked I’m on the verge of clawing my face off out of frustration.

    So far I’ve tried:
    Verifying the integrity of my game cache on steam
    Re-installing Chivalry
    Deactivating my firewall
    Specifically making sure Chivalry has public and private access through my firewall
    Opening ports for steam
    Removed suppress=devonline and suppress=devnet from the UDKengine.ini
    Deleted the Masterserver2.vdf, Masterserver.vdf and serverbrowser.vdf files
    Opted out of steam beta
    Manually connecting using the command console
    Having the game closed and choosing join friend from friends list
    Restarting Steam
    Restarting Computer

    There is probably a few more that I’ve forgotten as well but nothing has worked and this is really just depressing and stressing me out, if anyone has any idea of what’s wrong and how to fix it please help. As far as I’ve heard this type of issue isn’t exactly at the top of the to do/fix list which I think is stupid as besides this I have had next to NO problems with the game and the ones I have had have not been re-occurring constantly.


Log in to reply