"Please wait while the game loads"



  • Hey.
    I just bought the game and when i try to connect to online servers i get “please wait while the game loads” and the it times out.
    Ive been looking for the problem but i cant seem to find the fix.
    Anyone know how to fix this?



  • Same problem



  • Have you forwarded required ports to your computer (set on your router)?

    Are you running one of those programs that force steam to download from a specific ip address?

    Have you tried the general Steam trouble shooting stuff:

    Delete clientregister.blob (or whatever it is)
    Verify integrity of game cache?



  • I’m a long time player of this game and all of a sudden I’ve started experiencing this as well when trying to join servers. It seems about half I try just hangs on the “Please wait…” message. It is not a port problem.



  • Scratch that. I can’t join any server anymore.



  • @Toll:

    Delete clientregister.blob (or whatever it is)
    Verify integrity of game cache?

    Verify integrity did nothing. Do you have a path for that clientregister file? I can’t seem to find it.



  • you can try this which i think might be partially related.

    After further investigating, when i start the game via desktop shortcut it does not see the steam link but when i join a friend or launch it directly from steam library it shows the server list.

    So until they fix this issue try these steps.

    1. Launch via in Steam or Steam library.
    2. Join a friend via steams friends list. If it does not join directly it should take you to the main screen and just view server list.

    Hope this helps for people having the same issue i am having.

    ***I also have a 30 man server if anyone would like to play on it, we have a nice rotation of game play modes and maps. Server name is " [RP]Pimpin Medieval Wenches. " **



  • People play steam games not using the Steam library? Huh, Anyway let us know if that worked or not.


Log in to reply