Is all of the server info out of date?



  • I used to have a server up and running on my PC a few months ago, but cannot for the life of me get one working again. For clarification I hosted it on my PC and played successfully with friends and had other people join and it showed up in both the in game and the Java alternate browser. I have ports 7777, 7778, and 27015 forwarded from the last time I ran my server, I turned off my firewall, and I have followed all the steps in these posts backwards and forwards:

    Dedicated server download and configuration guide.
    viewtopic.php?f=72&t=9559
    (This thing is garbage and someone needs to update it and make it a lot less vague “your target may look something like this” thanks for clarifying. Can I just get a few “enter it just like this if you’re running it on your PC, or like this if someone else is hosting the server” )

    Dedicated server setup (old)
    http://steamcommunity.com/app/219640/di … 368930877/

    How to create a Chivalry Warefare Dedicated Server (old)
    http://www.youtube.com/watch?v=m5cmcw2khnU

    I’ve scoured the internet and forums but the lack of support in combination with all kinds of conflicting information has left me not only frustrated by generally pissed off. It’s disappointing that “Create Game” doesn’t allow you to automatically host a game in the first place as I feel that this should be a feature.

    I guess the main thing I’m looking for with this post is what kind of common user errors have people been making in setting up their server? I have no idea what I have been missing, trying different command lines and editing different .ini (the client side and the dedicated .inis) back and forth wondering if I read something incorrectly. I even uninstalled everything to make sure I hadn’t made a typo in a file somewhere that was screwing everything up. I’m at a loss and all the information is months out of date.



  • I’ll need slightly more specific questions.
    But I can say. The necessary config files are PCServer-UDKEngine.ini and PCServer-UDKGame.ini



  • Thanks for the response.

    The server looks like it loads fine and has the steam game server ID, but I can’t connect through “open” in game with the console and it’s not listed. I used to be able to a few months back.

    Here is my target
    C:\Steam\steamapps\common\chivalry_ded_server\Binaries\Win32\UDKLogging.exe AOCTO-Citadel_p?dedicated=true?steamsockets -seekfreeloadingserver -port=7777

    I’ve tried a few dozen different ones wondering if the target was the issue, but I don’t know.

    I guess the main thing I’m wondering is if the ports are forwarded and the firewall is off and the server appears to load fine, what could be keeping it from working/me from joining? I’m not sure what could be different from the last time I had it running. It seemed fairly simple and worked well enough when I figured it out the first time.



  • Did you also port forward the PeerPort and QueryPort? (Sorry for the very, very late response)


Log in to reply