Problem with custom maps



  • Hi there ! I have some questions.

    Before, i had no problem to open custom maps after cooking them. But now, it seems not working, saying map doesn’t exist. Do you have idea about this ?

    Then, i have a server, running on beta branch, working properly. But even if custom maps are in the good directory (CookedSDK/(PackageName)/, they are not recognized.

    Can you help me ?

    Thanks.



  • Yeah, I’m actually having a similar problem. No problem running the map from “- Launch game sdkcontent” but after cooking it (with no errors, all the files are there as well) and trying the normal “Launch game” in the beta it says “Map doesn’t exist” when the file is clearly there in CookedSDK.


  • Developer

    Can you PM me the package directory (zip it up, put it… somewhere)? Also, if you’re launching the game through a shortcut or batch file, the target you’re using to launch it? Thanks.



  • Sure thing. I’ve also tried opening one of the example maps, doing a Save As and then cooking it (exactly as in Nabsterhax’s video guide) and it still doesn’t work?

    EDIT: I tried again after adjusting the map and I simplified the names a bit and it worked!

    Instead of z0bmod (with a zero) I used zobmod as the package name and the map name I removed an additional hyphen. Something worked anyway.

    EDIT AGAIN: actually it seems to be something to do with which PC I use. For some reason my home PC will not recognise cooked packages at all?



  • I have actually released the beta of my map pack which have been tested so I can confirm that the problem is actually to do with certain installations or PCs not reading cooked SDK content.


  • Developer

    If you can, please post the UDKEngine.ini (Documents\My Games\Chivalry Medieval Warfare Beta\Configs) from any affected individuals, I have a hunch about it.



  • Here’s mine.



  • I noticed this issue as well. However, i fixed it by placing the map files in one of the following locations

    C:\Program Files (x86)\Steam\SteamApps\common\chivalrymedievalwarfarebeta\UDKGame\CookedPC\AOC\Levels

    Or

    C:\Program Files (x86)\Steam\SteamApps\common\chivalrymedievalwarfarebeta\UDKGame\ContentSDK

    Upon launching of the game/ or the SDK you get ambiguous package message. You simply press ok or the x button a bunch of times and it launches. I play my custom map with friends on a client hosted server.



  • Thanks for that, it does seem to work although the game runs slowly when doing that.

    Any word on this CrustaceanSoup? It still seems to be a problem with the most recent beta patch.



  • Any update? We’ve tried to upload my maps to a beta server but it had the same problem. I tried the solution suggested above by putting the maps into CookedPC\AOC\Levels but it crashed the server.

    If we have to wait until steam workshop or something that’s fine but I was hoping to test my maps on a server before then.

    Andrew? Crustacean?



  • I have a problem too. when i want to test my map it says that it can not join the host wheras i 'm the host. But at the same time i can refresh others servers and join them. That’s strange.


Log in to reply