[Bug] Attacking While Holding Parry Button With Shield



  • It appears as though there’s a bug where, say a Knight, can get stuck in a state where he can no longer press his attack key and have the attack key bring down the shield and proceed to attack. For example, under normal circumstances, if you’re holding the right mouse button (Default Parry key) and proceed to press the left mouse button (Default Attack key), your shield goes down quickly and you attack.

    When a Knight is in a bugged state (For reasons I have not been able to pin point), when you do the same executions, the shield will stay up and you will not deliver an attack. Once you let go of the right mouse button, after the shield completely lowers, your attack will launch as if it was queued up.

    The main problem with this is that if you’re in this particular bugged state, you cannot effectively strike, after a successful parry for example, because you have to wait for the shield to go completely down and then the queued attack comes into play. Normally if you press the attack key while you’re blocking with a shield, you do a very instant attack without having to wait for your shield to go down.

    In this bugged state, regardless of any player execution, it’s not possible. I’ve tried many ways to get out of this bugged state once I’m in it, but nothing consistent appears to work. Switching weapons. Putting my shield on and off. Doing a battle cry. Pressing all kinds of keys, including the reload button.

    I’m hoping this gets fixed anyhow.



  • To further elaborate on the issue in a smaller and more simple form:

    • (Normal Circumstances) Pressing attack key while holding block (With shield) results in an attack.

    • (Bugged Circumstances) Pressing attack key while holding block (With shield) results in nothing until your shield is completely put down by letting go of the blocking key and then an attack (Which is apparently queued) comes forth.

    • While I have not been able to pinpoint the exact cause, it does seem to happen somewhat consistently when blocking a Vanguard charge and persists (Indefinitely) until a proceeding block manages to get you out of this bugged state.



  • I’ve seen this as well…



  • Anymore information on reproducing this would be great, as I’ve had no success so far.



  • @Martin:

    Anymore information on reproducing this would be great, as I’ve had no success so far.

    Hadn’t realized this thread received any more replies. >.< The most consistent way I’ve been able to reproduce this is to get Vanguard charged close up. There’s many more ways for this to happen, but that is the most consistent way I’ve been able to reproduce this.

    The only way I’ve been able to fix this bugged state is to have a teammate hit me on my shield while I block until things become normal again. Granted this is not ideal in most situations.

    Once it does happen, I feel like it severely reduces your offense and makes you vulnerable to mistakes because you expect one behavior and receive another. For example, you’re holding block and you see an opportunity to attack, you press the attack key while still holding block. Nothing happens.

    After a moment, you let go of block and then when the shield is fully lowered, your attack comes out. You don’t expect this to happen so therefore you’re attacking at the air and a vulnerable target to someone counter attacking.

    Another thing I’d like to add is that this has happened with the tower shield (Knight) and the kite shield (Man At Arms - I think it’s the Kite shield. The bigger of the two shields for the Man At Arms). I’m not sure if it happens with the other shields as I don’t use them as much.



  • @Martin:

    Anymore information on reproducing this would be great, as I’ve had no success so far.

    Short description (at the very bottom):
    viewtopic.php?f=69&t=2086&start=160

    Detailed description:
    viewtopic.php?f=69&t=3149



  • I haven’t been able to reproduce this intentionally but sometimes shield bash will also experience the strange queueing bug and not execute until the player stops blocking, not just normal attacks.

    I think it occurs most often right after I dodge while holding the shield up, but I don’t know if that’s the cause. It might have to do with the previously mentioned running out of stamina and getting hit thing.

    Also this happened while I was using the buckler for MAA as well.



  • I have had this happen only too many times.