Please Help Me! (Chivalry not installing)



  • Hello, So after many attempts at trying to get this game to work again ive hit my limit and have turned to the forums for help.

    This first became a problem when after installing a new driver for my graphics card. This cause chivalry some problems and since I have not been able to play the game. I’ve tried verifying the cache, uninstalling and re installing, deleting the config files, launching UDK.exe as admin, deleting it from my documents which resulted in no success at all. I’ve almost given up on the game but due to the recent summer sale and with friends urging me to play their new game with them I’ve finally decided to come here for help. Just a quick reminder that the game has previously worked perfectly.

    I assume that my dxdiag info are needed for anyone to help me so figure ill save you the time of asking me :)

    Anyway would really appreciate the help and would be very grateful to anyone who can help me :D



  • Also something I forgot to mention was that I use Norton antivirus (hate it), not sure if there are any known fixes in case this is the issue but thought id mention it as i don’t fully trust that the program isn’t screwing with my computer. Thanks!



  • Yes, Norton has been a huge problem. Disable it and see if you can now join the servers.



  • First off…Thanks for replying! Ended up uninstalling Norton all together as I’ve been on the fence about getting rid of it for quite a while, Back to the subject though!

    So after removing Norton I tried the usual fixes such as running the installers for directx and vcredist as well as launching the game from the udk.exe and verifying the cache on steam. The game still doesn’t work and as soon as I click play the game pops up the box saying “Installing 1/3” and then vanishes… no splash-screen or anything!

    Again, any help would be awesome :)



  • BUMP



  • So I’m looking through your dxdiag and I find something along the lines of…

    Card name: Intel ® HD
    Graphics 4000.

    An intel 4000 is a POS integrated chip that won’t run this game at all. I’m surprised kimi didn’t see that.

    The minimum graphics card is literally twice as better than yours.

    So new graphics card time.

    Don’t get intel. If you don’t want to spend much but want good performance I would either get, on the NVidia side a GeForce 650 or 660.
    On the AMD side of things I would get a Radeon HD 7770 or 7790.

    One of those four cards. And any variation of them will do.

    Of course if its a laptop you are fresh outta luck as well you can’t really upgrade a laptop. Unless you get a new better one. If you buy a laptop look for the words “DEDICATED GRAPHICS” and you will be fine.



  • Thanks for replying man!

    The issue isn’t with the cards as this laptop im using uses nvidia’s optimus technology meaning that whilst not gaming the Intel HD 4000 is used and while gaming my other card the nvidia 650m is used. I’ve also made sure the card is launching chiv through the nvidia control panel so im not so sure that its a problem with the card as either way it won’t install. But yeah, thanks for your help anyway man… I appreciate it :D



  • I also use that card, and I can’t get the game to install either. When I first tried to install, it got to step 3 (installing DirectX) and my computer bluescreened. I thought that was odd, as my computer hasn’t blue screened before. I know I can run the game, my laptop is more powerful than my work desktop, and I can run it on my work desktop just fine.

    My laptop is running DirectX10 as well, so I’m not sure why it’s even trying to install directx on my computer. I’m not sure what to do at this point. I want to play Chiv at home, but currently I’m only able to play at the office, which might cause problems as you might suspect.

    I’ll have to wait till I get home to post my DxDiag, if that’s necessary.


Log in to reply