Cannot enable dynamic shadows.



  • I’ve been searching far and wide on these forums and elsewhere for people with similar problems but it seems i am a lone knight in this matter.

    I have no shadows in my game at all and no tweak or setting that i know of have enabled them (tried a bit in the .ini file as well). The game looks good but a bit barren without any shadows.

    I run the game fine at 60 fps at all times (except arena with 64 players, drops down to 25-30) on highest setting except for “particle resolution” which is at medium, furthermore i have these settings disabled/off;
    Dynamic lights, Depth of field (which is a real fps killer), true lightning, ambient occlusion, bloom, motion blur, Vsync.
    Dynamic shadows are on and most settings in the .ini file are default.

    Specs are:
    hd 5770 at 985mhz core clock/1370 memory clock and E8400 at 3.85 ghz, both relatively stable (ran 12h+ and i gain fps from these overclocks). Plenty of RAM and harddisk space.

    Any ideas? Known issue? I can post screenies if necessary.

    Best regards.

    Edit:
    here are some (relevant?) settings from my .ini

    ! [SystemSettings]
    ! StaticDecals=True
    ! DynamicDecals=True
    ! UnbatchedDecals=True
    ! DecalCullDistanceScale=0.500000
    ! DynamicLights=False
    ! DynamicShadows=True
    ! LightEnvironmentShadows=True
    ! CompositeDynamicLights=True
    ! SHSecondaryLighting=True
    ! DirectionalLightmaps=True
    ! MotionBlur=False
    ! MotionBlurPause=True
    ! MotionBlurSkinning=1
    ! DepthOfField=False
    ! AmbientOcclusion=False
    ! Bloom=False
    ! bAllowLightShafts=True
    ! Distortion=False
    ! FilteredDistortion=True
    ! DropParticleDistortion=True
    ! bAllowDownsampledTranslucency=False
    ! SpeedTreeLeaves=True
    ! SpeedTreeFronds=True
    ! OnlyStreamInTextures=False
    ! LensFlares=True
    ! FogVolumes=False
    ! FloatingPointRenderTargets=True
    ! OneFrameThreadLag=True
    ! UseVsync=False
    ! UpscaleScreenPercentage=True
    ! Fullscreen=True
    ! Borderless=False
    ! AllowOpenGL=False
    ! AllowRadialBlur=False
    ! AllowSubsurfaceScattering=True
    ! AllowImageReflections=True
    ! AllowImageReflectionShadowing=True
    ! bAllowSeparateTranslucency=False
    ! bAllowPostprocessMLAA=False
    ! bAllowHighQualityMaterials=True
    ! MaxFilterBlurSampleCount=16
    ! SkeletalMeshLODBias=0
    ! ParticleLODBias=1
    ! FoliageLODBias=0
    ! SSAOQuality=1
    ! DetailMode=2
    ! MaxDrawDistanceScale=0.900000
    ! ShadowFilterQualityBias=0
    ! MaxAnisotropy=4
    ! MaxMultiSamples=1
    ! bAllowD3D9MSAA=False
    ! bAllowTemporalAA=False
    ! TemporalAA_MinDepth=500.000000
    ! TemporalAA_StartDepthVelocityScale=100.000000
    ! MinShadowResolution=32
    ! MinPreShadowResolution=8
    ! MaxShadowResolution=170
    ! MobileShadowTextureResolution=1120
    ! MaxWholeSceneDominantShadowResolution=512
    ! ShadowFadeResolution=128
    ! PreShadowFadeResolution=16
    ! ShadowFadeExponent=0.250000



  • It is to my understanding that dynamic shadows doesn’t work without dynamic lighting turned on.

    I mean you explain how you get shadows without light.

    Personally I have dynamic lighting on with dynamic shadows turned off. Dynamic lighting has the biggest visual difference between on and off.



  • @lemonater47:

    It is to my understanding that dynamic shadows doesn’t work without dynamic lighting turned on.

    I mean you explain how you get shadows without light.

    Personally I have dynamic lighting on with dynamic shadows turned off. Dynamic lighting has the biggest visual difference between on and off.

    Edit: disregard it. It works now. The settings just seem to have reset every time i turned them on. Thanks!
    I don’t get any shadows from either settings. Tried configurating most of the settings. Sometimes they reset even though i enable them, but in my current game they are both set to “true” and i have no shadows.


Log in to reply