Framedrops in fights,tried almost EVERYTHING.



  • Hi,
    I bought the game on Steam Summer Sale and I REALLY like it. Except the fact that I get framerate drops “en masse”,as the french say.
    It happens almost everytime there are more than 5 guys fighting,and for some reason the framerate drops down to 40 everytime an enemy is right infront of me.
    In team objective the framerate drop all the time,while in ctf its relatively stable. Also some maps like Arena,stonehill the are with trebuchet 2 and citadel really suck in case of framerate.

    Here are my specs:
    AMD Phenom x4 840 3.2GHz
    Radeon HD 5770 Hawk 1GB
    4 Gb ram
    Windows 7 64-Bit.

    I already tried different LOW END configs and set EVERYTHING on low or off in the settings but still the framerate does not stay stable.
    In addition I used radeonpro, the video down below,set frameratesmoothing to false and tried all kinds of different config variations,but none really worked.
    Is there anything I can still do to get better performance?
    http://www.youtube.com/watch?v=gTTI1Zz4Lzs&list=WL6CDB1F1A3B24E4F6



  • Lol that’s my video.

    But ahh it doesn’t work for chiv anymore. Now everything comes up an an error and it only affects the splash image.

    And drops down to 40 FPS? From what? I have an i5 3570 8GB of RAM and a 5670 OC GI. And the highest frame rate I get at all is one citidel and its 50 FPS. On darkforest I get about 30.

    40 FPS is easily playable.



  • lol indeed about that video ;)

    Its not only the framedrop but theres is also some kind of mirco stuttering or something like that at that moment.
    And yeah 40 fps should be playable but for some reason it feels jerky when the fps drop. I mean my Pc isn´t the best,but it should atleast run the game with 60 fps at all time with these settings I play with. I literaly turned EVERY setting in the config off that could cost performance.

    I read that Chivalry is not really good optimized and even some high end pc struggle to get good frames all the time. Is that true?



  • @caliban:

    lol indeed about that video ;)

    Its not only the framedrop but theres is also some kind of mirco stuttering or something like that at that moment.
    And yeah 40 fps should be playable but for some reason it feels jerky when the fps drop. I mean my Pc isn´t the best,but it should atleast run the game with 60 fps at all time with these settings I play with. I literaly turned EVERY setting in the config off that could cost performance.

    I read that Chivalry is not really good optimized and even some high end pc struggle to get good frames all the time. Is that true?

    Messing with those configs produce very interesting results.

    I haven’t touched them. I have most thing on high nothing on medium and a few things on low. Vsync and dynamic shadows are off. Dynamic lighting is still on for me. And my ragdoll timer is on 150 there abouts and blood decals on full. I get about 30-50 FPS on 32 player servers depending on the map. With the exception of KOTH arena where I get about 6. But the fun aspect of that game mode on that map out ways the low FPS.

    Its people with the high end Nvidia cards which are having problems.

    What I do when I record chiv is I open the task as go to the processes tab. I right click on the UDK3 process as that’s what chivalry is and I change the priority to high. Putting it simply it makes your computer focus more on chivalry boosting FPS. Unreal engine games are really be only games that lag when running bandicam. So doing that puts my FPS back to where it should be. This will slow down most things in the background though. In fact with fraps I get a stuttered recording and the audio slowly gets out of sync from the video. But fraps sucks.

    Messing around with those configs probably made the game run really well with everything at a distance. But then everything gets up close and renders properly.



  • AMD Phenom x4 840 3.2GHz

    ^

    That is your problem. The only thing you can really do to increase your FPS is this (I’ve detailed this many times, in multiple threads, if you need convincing go find them):

    Open UDKEngine.ini. And search for the following two lines.
    [XAudio2.XAudio2Device] and [ALAudio.ALAudioDevice]
    Change MaxChannels to 32 or less in both.

    Be warned, reducing this means some sounds wont play if all channels are used.

    Don’t open your ingame settings screen as this can overwrite these changes.

    Seriously, this about all you can do settings wise. Also set your CPU to high priority and make sure you don’t have anything else running in the background that eats CPU.

    You can also attempt to overclock your CPU, make sure you have better cooling than the stock fan/heatsink though.

    Oh and make sure you have all forms of CPU throttling disabled.

    In the end, you probably wont really get higher than 40FPS.

    The reason maps like Arena lag more, is there is a much of extra CPU related stuff going on, like PhysX ragdolls (due to higher kill count) and cloth physics. Set your ragdoll settings to 5 or less. This means dead bodies will stick around, eating CPU cycles for 5 seconds then disappear, just enough time to chop of their head and tea bag them (that is important).

    If you set it to 1, bodies can disappear before they hit the ground and it just feels silly.

    If you want a solid 60FPS, then you have to stick to servers with 16 people or less (16 may even be pushing it).

    I have a phenom 955BE, and 560ti HAWK. My CPU is running at stock and is certainly the bottleneck, I have proof in other threads. Your CPU is less…



  • Hello,

    Seems like you have an AMD CPU. Have you tried disabling AMD cool and Quiet technology in the Bios?
    This could be a CPU throttling issue that is apparent with the UE3 game engine. Try it out and see if it works.

    Google how to do that in the Bios.



  • Whilst doing that does help, going by what he has it is working correctly or he has already disabled it. Simply put his CPU doesn’t have the grunt to run Chiv at 60fps on a 32 player server.



  • First,thanks for all the replies ;)

    I already have cool and quiet disabled,so that shouldn´t be the issue.
    Maybe my CPU really is too weak,but I will give the maxchannels thing a try,so thx for that :)

    Is there actually a way to disable Physx in Chivalry? I mean for example in Borderlands 2 you could disable it,by just uninstalling it. Or is Physx actually the slidebar in the ingame settings?
    And is it possible to change the config so the quality is worse at close distance too? I don´t need any eyecandy at all :D



  • 3.2 ghz my bad, it seems the above poster is correct.

    You could try to overclock, but I don’t recommend this if you really don’t know what your doing.



  • Overclocking in the bios often means your CPU doesn’t hear up nearly as much. I can overclock my i5 3570k to 4.0GHz and my CPU gets in between 50-60 degrees. I try the turbo boost to 3.8 and its peaking at 70 degrees. And I wouldn’t dare turbo boosting to 4.12GHz.

    And that’s all the stock cooler. And two case fans intake and outtake.

    Personally I would only look to get a better cooler if it overheats. Though since its AMD its probably going to. Though I’ve never overclocked an AMD CPU myself.


Log in to reply