How to bind keys?



  • I’ve been trying the

    “Setbind <key><command></command>”

    and it’s not working.

    I’ve been trying to input it so I can just push * on the numpad to login as admin and push / on the numpad to cancel a vote. Any help? Everyone I ask says the same thing which is the command above but apparently that doesn’t work anymore. I just get some error message about a Bindname when I try to put it in.</key>



  • @Smac3223:

    I’ve been trying the

    “Setbind <key><command></command>”

    and it’s not working.

    I’ve been trying to input it so I can just push * on the numpad to login as admin and push / on the numpad to cancel a vote. Any help? Everyone I ask says the same thing which is the command above but apparently that doesn’t work anymore. I just get some error message about a Bindname when I try to put it in.</key>

    From what I recall you have to type numbers out as words. So if you mean the number 8 (or asterisk *), then you’ll have to type out eight.

    Setbind eight command

    Hope that helps.



  • “NumPadEight” is for the number pad 8

    Look at this documentation for all keybinds in unreal engine

    http://udn.epicgames.com/Three/KeyBinds … cal%20keys



  • Trying to put * on the numpad as admin login.
    Trying to put / on the numpad as cancel vote.

    I just tried to input setbind Numpad * adminlogin <password>and nothing happened</password>



  • @Smac3223:

    Trying to put * on the numpad as admin login.
    Trying to put / on the numpad as cancel vote.

    I just tried to input setbind Numpad * adminlogin <password>and nothing happened</password>

    You won’t be able to do those odd characters unfortunately. That’s why I was saying to use eight - since it’s the same key as *, unless you are using a different keyboard than me (American).



  • No matter how I phrase it it won’t seem to go…

    Can someone just tell me what to type in to set…

    F1 to Admin login
    F2 to Cancel Vote



  • @Smac3223:

    No matter how I phrase it it won’t seem to go…

    Can someone just tell me what to type in to set…

    F1 to Admin login
    F2 to Cancel Vote

    Smac, we understand what you’re saying, but the one you wanted to do before, you weren’t able to.

    To do function keys:

    setbind function one command
    setbind function two command



  • You can only setbind commands to letters. It won’t let you do anything else. Though if typing out the character works that would be useful.

    I have mine set to O. As nothing else uses it and its easy to push.



  • Still doesn’t seem to be working…

    Considering F1 is the way you move onto a different spawn in TO I decided to just change it to “R”.

    So I typed in…

    setbind Letter R adminlogin ****

    Where the * denotes my password. When I press enter for it nothing pops up but it looks like the command console just accepts it. However when pressing “R”, I do not log in.



  • @Smac3223:

    Still doesn’t seem to be working…

    Considering F1 is the way you move onto a different spawn in TO I decided to just change it to “R”.

    So I typed in…

    setbind Letter R adminlogin ****

    Where the * denotes my password. When I press enter for it nothing pops up but it looks like the command console just accepts it. However when pressing “R”, I do not log in.

    Type it like this and it will work:

    setbind R adminlogin password

    Mine is set to O and it works just fine doing it this way.



  • My password is four numbers. They’re whited out for obvious reasons.

    I’ve tried it all of the above ways and following entering it as such and pressing “R”. Nothing happens. Am I doing something wrong? Does some prerequisite need to be met or something done in order for this to work?



  • @Smac3223:

    My password is four numbers. They’re whited out for obvious reasons.

    I’ve tried it all of the above ways and following entering it as such and pressing “R”. Nothing happens. Am I doing something wrong? Does some prerequisite need to be met or something done in order for this to work?

    It doesn’t always show you as logging in. Have you tried doing an admin command to see if it works?

    The only other thing I can think of is you have too many setbinds so you might want to clear them out. At your own risk, you can open up the UDKGame.ini file in My Documents\My Games\udkgame\config and close to the bottom where it says BINDINGS= you’ll see all your bindings . You can search for the one in which you bound R - it might list multiples. You can delete them all and try again in console.

    Or if you don’t feel comfortable doing that, you can try deleting the Chivalry folder from MyDocuments\My Games (this will reset all video settings and custom keybinds) and so you’d have to redo them again.

    It’s up to you which you choose. Hopefully that didn’t confuse you too much.



  • When I did it I had the letter you wanted to bind in lower case.

    Also r by default is bound to reload. Though I would have expected it to do both. As code wise it would go down the code executing all methods.

    I bound my admin login to the letter o. As nothing by default is bound to it.

    So…

    Setbind o adminlogin 1234

    It won’t log you in. You have to push your admin login bind for it to work.


Log in to reply