Low FPS (framerate)



  • Hello. I am a big fan of this game, I love it. I was just noticing that this game is suffering from optimization issues somewhere in the UT3 engine. I get roughly 40-60fps at times, but it can drop to 20-30fps. My specs:
    gtx 580
    q9550~3.8ghz
    4 gigs ddr3 ram
    790i mobo

    The game Red Orchestra 2 also runs on UT3 engine and is fairly new. When it was first released it use to run terrible as well, it took them half a year (and the loss of all their playerbase) to finally fix the issues. The game (RO2) now runs at a constant 60+ fps, but no one plays it anymore.

    I really hope this game can get fixed up, because it really is a lot of fun!



  • Can you give more details about what situations you’re experiencing FPS drops in? Where on what map, number of players on screen/in the server, etc.



  • Yeah for sure, I’m going to go play a little more so I can write down the map names, because some maps are better than others.

    Definately player number is a factor as well. I’ve noticed that past 12 players on server and the frame rate gets wrecked.

    Also, I’ve tried running on all low settings and it doesnt seem to effect it much.



  • Yeah, I tested it a little more, and it seems to drop my framerate on every map so long that theres 10+ people on that server.

    But if theres like 5 or 6 people, its pretty smooth.

    Is there any more information that can help out with this issue? Am I alone in this issue?



  • Not sure why the 580 is behaving like that, have you tried updating your drivers?



  • Can you try this and see if it makes it better?

    Hey can you try something,

    If you go into My Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKEngine.ini, can you search for
    MinCompressedDurationGame and set that to a number like 3. Let us know if that improves performance.

    If that doesn’t make any noticeable difference can you type ‘stat unit’ into the console too and let us know what those numbers are.



  • @b3h47pte:

    Can you try this and see if it makes it better?

    Hey can you try something,

    If you go into My Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKEngine.ini, can you search for
    MinCompressedDurationGame and set that to a number like 3. Let us know if that improves performance.

    If that doesn’t make any noticeable difference can you type ‘stat unit’ into the console too and let us know what those numbers are.

    AWESOME! Thank you!

    I just did this and updated my drivers (from 302.21 to 306.23), and the game never drops below 62 fps, I was just testing on a server with about 12 people and it was great! Thanks again!

    editBattlegrounds still drops to 30 at times. But most other maps are pretty good.



  • Talked to Mr. Goat in game and he said to check this thread.

    Updated my drivers and tried the “MinCompressedDurationGame” set to 3 and it runs a little better now, I can get 60 FPS up to about 20 players, 8-) where before if there was anywhere near 10 people my FPS would drop like a rock.

    My specs are; Intel i5 2500k and nVidia EVGA GTX 560TI, with 8Gb of RAM, and an Asrock Z68 E3G3 Mobo.



  • Hello,

    I have a similar problem, in games with more than 10 players I get 10-20 fps only… I changed MinCompressedDurationGame to 3 and it improved a little bit but not enough.

    I have a ATI Mobility Radeon HD 5400 I checked the numbers on stat unit:
    Frame: 60 without doing anythin (150 when people fighting)
    Game: 50-60 (150)
    Draw: 45 (60)
    GPU: 45 (60-70)

    Any help? Thanks



  • This makes me immensely worried.

    I recall RO2. You had double the recommended on release, you could get 20-30 FPS at times as well. Lost their entire playerbase by having a very short open beta and releasing it despite the fact the beta was plagued with bugs. The developers worked hard to fix them, but it did indeed take half a year before it got to release status.



  • Battlegrounds had some issues that have been worked out for this patch. No worries, we are hard at work on these things :)



  • Well as long as you guys are ready to release and aren’t releasing to meet fan expectation, I’m all good.

    I’m sick of products being rushed to release lately, then fixed with patches over hte course of months, while the game dies.


  • Developer

    @Lorac:

    Hello,

    I have a similar problem, in games with more than 10 players I get 10-20 fps only… I changed MinCompressedDurationGame to 3 and it improved a little bit but not enough.

    I have a ATI Mobility Radeon HD 5400 I checked the numbers on stat unit:
    Frame: 60 without doing anythin (150 when people fighting)
    Game: 50-60 (150)
    Draw: 45 (60)
    GPU: 45 (60-70)

    Any help? Thanks

    It sounds like you’re bottlenecked by your CPU. What are your full specs, including the CPU?

    Bear in mind, your GPU is also a good deal below our minimum specs (a Geforce 8800 GT or Radeon HD 3870).



  • My computer is a Pentium with i3 2,3GHz, 3GB RAM

    I downloaded new drivers for my graphic card and I changed resolution to 800x600 and I got 30-40 fps which seems enough to play.

    Would it be possible to even go further down with the lvl of graphics? I mean right now there is from Low to High, what about a superlow? where all the non-necessary details like castles and other big buildings or detailed parts of the scenario are not even loaded fully?

    Thanks



  • Weak CPU and not to much ram for todays world…what GPU?

    I’d say a new system.



  • My GPU i a ATI Mobility Radeon HD 5400
    Its a laptop almost 3 years old… Economy is not on his peak right know for a new system… but I guess for next year I’ll change. Anyways the game seems at least playable, which is fine. I only have some problems in some scenarios.



  • @Mkilbride:

    Weak CPU and not to much ram for todays world…what GPU?

    I’d say a new system.

    Aren’t you the guy who was saying the game should be lowered to $20 to bolster the playerbase? Seems a little contradictory to advise people to buy an entirely new system to play a game you think is worth $20 :?



  • Yes, that’s me.

    But this and that are different things.



  • Well before the new patch I got around 40-50 fps using game boosters and changing some other settings but just after the patch it goes down again to 25-35 fps with low peaks of 15… is that patch influencing FPS performance in any way?



  • Your settings may have been reset, try setting everything to low again?