Dedicated Server problem - ports not opening



  • I have a Arriss dg860 modem/router through TWC. I’ve open ports 7777-7778, 27015 in the router settings.

    Target looks like:

    ! “C:\Program Files (x86)\Steam\SteamApps\common\chivalry_ded_server\Binaries\Win32\UDKLogging.exe” AOCFFA-Arena3_p?steamsockets -seekfreeloadingserver -Port=7777 -QueryPort=27015 I have only attempting to run 1 server so don’t believe I need to use multi command.

    PFPortChecker.exe says the ports are “NOT OPEN or not reachable” and
    canyouseeme.org says lists “Reason: connection refused” for those ports.

    I’ve set up a static internal IP, reset router and the windows 7 machine the server is attempting to run on.

    I have tried disabling windows firewall and put my computer in the DMZ through the router settings and get the same responses from PFPortChecker.exe and canyouseeme.org

    Anybody have any ideas?



  • I think your close but you should bind it to your internal IP i.e 192.168.x.x or 10.1.x.x
    because your game is not directly connected to the internet ( just keeping it simple) alot of games needs to bind to your local IP and if you do not define it in some cases it will try to bind to your external IP and it can’t . If the software already binds to the local IP than you will need to make sure port forwarding is enabled/ forwarding the ports to the correct local IP .

    i.e Port 7777 forwards to 192.x.x.x.x <–- the ip of the game server.
    Hope this helps



  • well if the router is set for the port to be open to only one internal ip, then shouldn’t the router forward any requests to that machine? Are you suggesting using the -multihome command? I’m now testing with -multihome set to the internal IP of the server. It’s still not allowing others to connect and not showing on in-game server list.

    I think my issue is the ports aren’t forwarding even though I’ve forwarded them in router settings, even with windows firewall off and the machine put in the router DMZ.



  • Would DHCP being enabled be an issue? Even though I have set static internal IP.



  • Hi no DHCP just assigns your IP normally that never changes and lease times are 3 days on most configurations.
    Let start from the OS level than work our way to your router.

    1. Are you running any Anti virus software that has a built in firewall or are you using Windows firewall?
    2. Have you included the firewall exclusions and add it to the exception list.
      assuming your running windows 7 … Go to Control panel > Administrative Tools>Windows Firewall with Advanced Security> On the left click on Inbound Rules > Right click on Inbound Rules and click on New Rule… leave everything there and click on next > Select This program path should be selected already and browse to the game EXE UDK.exe Click next >Select allow the connection click next> Keep all 3 checked and click next>Name just put anything i.e CMW Server and click finish>
      Now what you did was any ports the game wants to use it will open .
      let me know when you have completed that so we are on the same page


    1. I’m running MSE(microsoft), it doesn’t have a firewall.
    2. Using Windows 7, I’ve added UDKLogging.exe to the exceptions list(windows firewall).


  • Ive made an error should be UDK.exe add that to the list.



  • actually you did say UDK.exe I just assumed since I would be using UDKLogging.exe I would add that one to exceptions.

    I’ve now added UDK.exe to exceptions.



  • I honestly feel some programs tries to bind to your external IP So I suggest that force it to use the IP of your computer /server that way we are sure nothing screwy going on there .

    Now your command line should be something like this you can try multihome or not .
    Binaries\Win32\UDK.exe AOCTO-Stoneshill_P?steamsockets -seekfreeloadingserver -Port=7777 -QueryPort=27015 -maxplayers=32 multihome=YOUIP ( this is the IP of the local machine if it is a dedicated server connected directly to the internet then use one of its IPs)

    If you are running it on your local network and you are connected with your computer first try to see if you can connect to it without using the external IP if that is possible .

    Also verify that the UDK or UDKlogging is running on another note I just thought of have you installed the Microsoft Visual C++ 2010 Redistributable x86 and 2011 ( its required to run the game)



  • Couple of things to check, sorry if this stuff is obvious:

    You’ve opened ports on your router. I’m assuming this is both outbound and inbound on BOTH TCP and UDP? I’m fairly sure those port checky sites you mentioned only scan TCP btw

    Port forwarded inbound ports to the IP of your machine, which has been assigned a static IP and the machine definitely has that IP?

    I’d agree that the ports aren’t being forwarded or are being blocked. One testing option would be to set the router to forward all inbound/outbound UDP/TCP ports to the machine IP (temporarily) that way you’ll find out whether the issue is machine side or router side

    good luck! :D



  • You could take a different method, instead of relying on your router to filter your inbound connections, you can set your router into DMZ mode for your server’s MAC address. This would essentially be the same thing as connecting straight to your modem, bypassing your router’s firewall.

    The only downside is, you’d need a good software firewall on your system to make up for it. MSE is not really going to cut it.



  • I still haven’t been able to get it to work, regardless, thank you all for your responses.

    @TrinityGames:

    I just thought of have you installed the Microsoft Visual C++ 2010 Redistributable x86 and 2011 ( its required to run the game)

    I can run chivalry just fine on the same computer, so those must already be installed correct?

    @MonkeyFiend:

    Couple of things to check, sorry if this stuff is obvious:

    You’ve opened ports on your router. I’m assuming this is both outbound and inbound on BOTH TCP and UDP? I’m fairly sure those port checky sites you mentioned only scan TCP btw

    Port forwarded inbound ports to the IP of your machine, which has been assigned a static IP and the machine definitely has that IP?

    I’d agree that the ports aren’t being forwarded or are being blocked. One testing option would be to set the router to forward all inbound/outbound UDP/TCP ports to the machine IP (temporarily) that way you’ll find out whether the issue is machine side or router side

    good luck! :D

    TCP and UDP are both open for those ports in the router settings. I’ve checked using one of the websites and PFPortChecker.exe, portchecker says the ports are not opened, website says it got no response.

    Machine is set to a static internal IP. I’ve double checked to make sure I had the right IP multiple times.

    I’ve also tried opening all inbound/outbound UDP/TCP ports and set the machine in the DMZ

    @cjkupers:

    You could take a different method, instead of relying on your router to filter your inbound connections, you can set your router into DMZ mode for your server’s MAC address. This would essentially be the same thing as connecting straight to your modem, bypassing your router’s firewall.

    The only downside is, you’d need a good software firewall on your system to make up for it. MSE is not really going to cut it.

    I’ve tried opening all ports and setting the server in the DMZ, while disabling all firewalls, the ports still won’t show as opened.

    I’ve called my ISP(TWC) and they said they don’t have any ports blocked. They also mentioned that my IP is assigned dynamically, but my IP would only change if their servers went down and had to reassign IPs. Their cheapest static IP service costs $200/mo so it’s not something I can even test if it is the issue, but they did mention other people host game servers with my service.

    Could they be misinformed? And I’m not really sure how to go about finding out if it’s my ISP modem/router that’s causing the problems.



  • Regarding the dynamic IP, this is fairly common (but chuffing hell, that’s expensive for a static :O). IP leases from your ISP would be normally 24 hours and tend to just pick the same one up when it expires.(lease times are in ipconfig /all) The IP tends to get changed if you connect with a new device or leave your router off during the period where you lease expires and the IP would be returned to a usable pool.

    Typically speaking your IP won’t change that often. Also many routers support sites like dyndns so if you public IP changes it’ll automatically repoint to the new one.

    Back to your problem though well I’m still baffled… the only thing I can think of would be something on the machine blocking it, like some arsey anti-virus, software firewall or overzealous anti-spyware. Aside from plugging in another machine (or possibly hosting a vm on the current machine) I can’t think of any way to narrow it down further :S



  • I think I may have caught your issue. Since it’s not a router issue, or an ISP/ IP assigning issue, nor is it a software firewall issue, it has to be something much simpler and easily overlooked than that.

    I re-read your OP and found out that you’re using two arguments in your startup line that are a little wonky.

    Your startup arguments:

    "C:\Program Files (x86)\Steam\SteamApps\common\chivalry_ded_server\Binaries\Win32\UDKLogging.exe" AOCFFA-Arena3_p?steamsockets -seekfreeloadingserver -Port=7777 -QueryPort=27015
    

    My own off-site 24/7 Dedicated host:

    AOCTO-Hillside_P?maxplayers=32?steamsockets
    

    Here’s some information that might help explain your issues:
    from 1024-49151 are ports registered to specific applications and programs, and if you look at
    http://en.wikipedia.org/wiki/List_of_TC … rt_numbers
    You’l see 7777 is of course standard for Unreal Tournament servers, but also for a buttload of other different servers as well. If you run any clients OR servers of those applications listed simultaneously, You’ll get packet redirection problems. Data from both your server and from whatever else uses that port will have problems handling that sort of port sharing.

    second off, your argument line is a little odd. you have port=7777 and then queryport=27015.

    Players will not be able to see your server in the server browser because the default port it listens on for clients is port 27960, not 27015.

    My server uses port 6000 for its standard port, perhaps you need to change it to that? These ports you’re using just seem to be very oddly picked. Also, check and make sure your ports are also specified in your UDKGame.ini and similar necessary files in your UDKGame folder.

    If your internal server configuration .ini’s say another port than what you’re attempting to run the server.exe with, you’re going to run into issues.

    Lots of simple things that you should check on.



  • errm not too sure about some of that last post… my games ports are set to figures such as 11304 and 15745, it doesn’t matter on the numbers as long as they aren’t reserved or in use elsewhere.

    The query port is used for querying the server to the master server, then everyone queries the master server for a list. Again this query port can be set to anything. For security reasons I won’t mention what mine are, but they are both high unused port numbers

    Also you don’t have to specify a max players on the commandline, although many people do



  • His .ini configs could be mismatched with his startup arguments.

    Just saying, port 7777 is used by way too many things.



  • Thanks for the help guys. I’m been more busy than normal but when I get around to it I’ll make sure to get back to this thread after I’ve tried some of the suggestions.


Log in to reply