[SOLVED] Authentication failed suddenly on official servers?

  • Hey guys, not sure why but I’m getting an authentication failed message when I try and connect to official servers; not sure if this is why, but I tried cheat-engine a few days ago for about 5-10 mins; in order to confirm a suspicion I had about a massive hacking issue I was experiencing in games. Needless to say I uninstalled it and made a post about the problem on the main-forum. All was fine until today.

  • Developer

    In UDKEngine.ini (in Users<user>\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config), remove the “Suppress=DevOnline” line

    Start the game, close it

    Open the log in Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs\Launch.log

    Look for a section that looks like this:

    [0038.28] Log: Initializing Steamworks
    [0038.29] DevOnline: Steam ID: ...
    [0038.29] DevOnline: Steam universe: PUBLIC
    [0038.29] DevOnline: Steam appid: 219640
    [0038.29] DevOnline: Steam IsSubscribed: 1
    [0038.29] DevOnline: Steam IsLowViolence: 0
    [0038.29] DevOnline: Steam IsCybercafe: 0
    [0038.29] DevOnline: Steam IsVACBanned: 0
    [0038.29] DevOnline: Steam IP country: CA
    [0038.29] DevOnline: Steam official server time: 1375805711
    [0038.29] DevOnline: Steam Cloud quota: 1000000000 / 1000000000
    [0038.29] Log: Logged in as 'Name'

    See that “IsVACBanned” line? If that’s 1, you’re VAC banned. Refer to https://support.steampowered.com/kb_art … -QDHJ-5691

    (VAC ban status will show on your Steam profile somewhere, but may show up after a delay whereas this will show as soon as you’re banned)

    EDIT: Assuming this is the same user as in IRC, we’ve confirmed he/she is indeed VAC banned; although their Steam profile was still showing no VAC bans on it, the log shows:

    DevOnline: Steam IsVACBanned: 1</user>

Log in to reply