UDK.exe problems



  • Hello all,
    I have picked up my copy of Chivalry today, and was very excited to play it. I downloaded it without a hitch, and all seemed to be going well. When I started to launch it, it immediately said
    something like:

    “UDK.exe is not working
    Windows is searching for a problem.”

    This then forced me to close the program, and I can’t play it at all. I have un-installed and re-installed it 3 times, verified the game cache, followed all of the other peoples solutions but with no sucess. As far as I know, my system meets the requirements of Chivalry, and don’t understand the problem. I am using Windows XP, have 3gb of RAM, DirectX11 and a 3.0 GHz processor.

    If anyone has a potential solution or has had the same problem, any help would be very much appreciated.

    Many thanks for reading,
    Lgurney66



  • look in your event log and see if there’s anything indicating what may be causing the problem. Every time your computer errors, there will be a log of it. At least check that first. Right click my computer, go to manage. On the left hand side of this window, go to event viewer and expand it. Then go to windows logs, applications logs. Try to make the game crash before looking here, but after it crashes you should see like a red x , click the error and see what it says. Usually there’s a faulting application of some sort causing the crash.

    You say you tried all of the solutions but i highly doubt that, there’s a post that list a bunch of them usually at the top of this subforum.

    Are you running anything on the side that may conflict?

    You also don’t give much info about your computer specs… a 3.0 ghz processor for all we know could be a single core. You don’t mention your graphics card either, chances are your specs don’t meed the minimum requirements too… but at least look at your logs and see what they say.

    There’s also a launch log in your chivalry game folder somewhere too, never had to look for mine.



  • Dear Clayton-Bigsby

    Many thanks for writing in! I followed what you said ( which was clearly told, thanks!) and it came up with some thing like this:

    Faulting application UDK.exe, version 1.0.10246.0, time stamp 0x51d71a06, faulting module MSVCR100.dll,version 6.0.6002.18451, time stamp 0x4ec3e3d5,exception code 0xc0000135,fault offset 0x00009f5d, process code id 0xdddc, application start time 0x01ce93b1a6979ee0.

    I don’t know about you, but I don’t know what this means! It says here that UDK.exe was the problem like what I thought in the beginning but I am not sure what to do of it!

    Sorry about the minimalist info on the PC specs, here they are:
    OS: Windows Vista Home Premium (sincere apologies, didn’t realise it was vista)
    System model: Dell DM501
    BIOS: Pheonix ROM BIOS PLUS version 1.10 A07
    Processor: 4 CPU 3.00 GHz (2CPU’s) ~3.00Ghz
    Memory: 3070 mb RAM
    DirectX version: DirectX 11



  • ah cool, check this thread out:

    viewtopic.php?f=69&t=10565

    seems to be an issue with your microsoft c++ redistributable package, you can uninstall and re-install these. Basically just go into programs and features in control panel, and uninstall any of the 2010 c++ redist’s and then re-install them with the files located here:

    C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\RedistChiv

    Follow the instructions on the 2nd post down on that thread i mentioned but it says the same thing, and you can see a visual screenshot of this the 4th post down. Hope that helps.



  • Dear Clayton-bigsby,

    Thanks for the quick replies! As I have said with my first post, I have tried many (Don’t know why I exaggerated it to “all”!) solutions to the problem yet with no avail, including the one suggested.

    Thanks for reading and writing,
    Lgurney66



  • I would try uninstalling all of the 2010 packages again, reboot…

    then you can try these links

    For 32-bit, refer to this link: http://www.microsoft.com/download/en/de … px?id=5555
    For 64-bit, refer to this link: http://www.microsoft.com/download/en/de … x?id=14632

    If you don’t know whether you have 32 bit or 64 bit windows, right click my computer and hit properties, will tell you on the main page there.

    If you’re all up to date there:

    also, someone else tried the fixes you did, but they copied from a backup… so they had to delete the config folder under my documents/mygames/chivalrymedievalwarfare/config
    Could also be located C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\config… but for me it’s the first one, this is if you copied any files but you said it was clean install.

    … just delete the entire config folder, reverify the files, and then start the game up.

    Based on that error, it sure seems to be that 2010 redist packages that are causing the crash. If you delete them, you could also THEN try to re-verify the files for chivalry within steam and have it re-grab those for you. Might even do it automatically if you attempt to start the game up after installing but not sure on that one. Sucks it’s not working for ya.



  • Dear Clayton-bigsby,

    So many thanks for taking the time out of your day to help me with all of the solutions and finding all of these links. I am trying them all again to be thorough! I am going to re-install Chivalry just to get a clean copy.



  • i hope it works man



  • Dear Clayton-bigsby,

    Thanks for all of your help but even after all of the solutions, none have managed to make the UDK.exe work. That’s a lot of time and now money down the drain D:

    Many thanks for your time
    Lgurney66



  • Dear Anyone,

    I have just realised that I am missing the file MSVCR.100.dll (I think it is called that). If someone could tell me where this file is meant to go it would be very much appreciated! I have gotten rid of the microsoft c++ redistributable packages if it helps.

    Thanks for reading,
    Lgurney66



  • that’s the 2010 version i was telling you about, if you got all of them uninstalled, follow that link and re-installing should also of course get you that dll file.



  • Just read this tread and had to say; clayton-bigsby you really are a diamond gezzer.



  • @Reginhard:

    Just read this tread and had to say; clayton-bigsby you really are a diamond gezzer.

    huh? i’m trying to help him lol but i’m not sitting at his computer so gotta do the best i can via text.



  • @clayton-bigsby:

    @Reginhard:

    Just read this tread and had to say; clayton-bigsby you really are a diamond gezzer.

    huh? i’m trying to help him lol but i’m not sitting at his computer so gotta do the best i can via text.

    Sorry pal; guess I lost you there…

    The phrase ‘Diamond Geezer’ is London slang; the Oxford slang dictionary defines a ‘Diamond Geezer’ as …

    A really wonderful man, helpful and reliable; a gem of a man. A commonly heard extension to ‘diamond’. [Mainly London use] meaning a good ‘solid’ reliable person.



  • Dear Reginhard,

    Can’t agree with you enough. I am/ have tried his solutions and am trying them again. But for now, I have never been so dissapointed by a game. I wanted Chivalry ever since release, and for it to fail so close to me playing it is a huge disappointment.



  • @lgurney66:

    Dear Reginhard,

    Can’t agree with you enough. I am/ have tried his solutions and am trying them again. But for now, I have never been so dissapointed by a game. I wanted Chivalry ever since release, and for it to fail so close to me playing it is a huge disappointment.

    Yeah; that must be a bitch but whatever you don’t give up. IMHO this game is something else (of course it’s not as good as it used it be etc etc etc lol). I’ve played close to 900 hours and I can see myself playing at least another 900.

    We did just get a weird patch and a few people are saying that the game is crashing for them so this might have something to do with it. Still, I’ve eaten cheese that has a better understanding of technical issues than I have so what do I know.

    PS. I’ll link this back to our site, see if any can help.



  • Hey guys,

    Here is what I have done so far to the game:

    Un-install/reinstall 4 times
    Uninstalled Microsoft Visuals 2010 files and reinstalled them from the file you have given me
    Verified game cache 7 times
    Deleted config folder/verified

    You can probably name another method,but I can guarantee I have done it. Is there any other methods you can think of, or is my game completely screwed up for eternity?

    Thanks for your time,
    Lgurney66



  • I fear I must just leave this game now. I have tried to fix it for over 7 hours now, and that is excluding installation time. This would have easily been my favourite game of all time. It’s the only realistic medieval first person I know of except Mount & Blade, but that’s no where near as good as Chivalry. All of my friends have it.

    For probably the last time,
    Thanks for your help,
    Lgurney66



  • @lgurney66:

    I fear I must just leave this game now. I have tried to fix it for over 7 hours now, and that is excluding installation time. This would have easily been my favourite game of all time. It’s the only realistic medieval first person I know of. All of my friends have it.

    For probably the last time,
    Thanks for your help,
    Lgurney66

    Got this back…
    [Knight] LadyBunBun ask him to, if he purchased via steam, to install on different computer and then usb move the save folder to his original computer. then verify and launch.
    [Knight] LadyBunBun save folder = entire game folder. sry

    Don’t understand what she means but I hope it helps



  • I think she means I could take the files from one computer from the other, but I purchased it from
    GAME as I only had enough money to buy it after the steam sale.


Log in to reply