Post-Update "AlternateAttack" bug



  • Hello,

    I already checked yesterday with my friends and a room full of players, nobody can make this work. After the update we cannot start a left-sided attack pressing ONE button.

    If you assign a key to ALTERNATE ATTACK, any kind of key (mouse buttons/scroll wheel or keyboard), the game completely ignores the assigned key and does nothing during a fight. All the other attacks seem to work if you assign a key but ALTERNATE ATTACK won’t, at the moment.

    Note: I tried to restart the game, it doesn’t fix it. A temporary workaround is to use the combo ALT+attack, which means pressing one button more + moving around (for an action game you should know what it means to add also one useless button only to all your real-time pressing) and it’s obvious less practical and slower, even half a second more in executing an attack means you’ll be parried as it doesn’t surprise anymore. Also sometime ALT+atk fails (not for bugs, just for user error, when you press alt and attack so fast it happens to recognize the “attack” first and makes the right-sided one), which means your attack gets shielded and you’ll probably die few seconds later. I’m sure some players are used with that combo and I don’t care, I don’t even want to discuss if it’s better 1 button or a combo to make the same action, the bug esists, it is affecting all (even if you don’t use that attack) and now it’s reported.

    I feel to not play Chivalry until I can do ALL my attacks again = assign a key for each of them (I was used to “mouse wheel up” for that and it worked before), I feel like going to war with one arm only at the moment.

    Please let me know when it’s resolved in some way.

    Thank you,
    Marco/Thunder



  • works fine for me



  • This might be a silly question, but did you rebind it after the patch? As it resets your controls to default.

    Working fine for me too.



  • I found out how to resolve, in case it happens to others too.

    The assigning was indead bugged, I deleted the keys and reassigned several times after patch, also today, and it wasn’t working.

    After reading your two posts I understood that, as some peoples didn’t have the issue, I simply had to reset all buttons to default and put it back again (like when you format a pc, you start from zero) and it finally works fine (maybe you two guys had your buttons already and always to default I though).

    Anyway matter seems resolved to me, but I think there is still something wrong in that part, also when you select a button to change very often it select the secondary of another line (another attack or movement for example) and some of the keys were impossible to delete or change, like the mousewheel I had put for that alternate slash.
    I’m sure peoples who change several buttons (instead of using default ones) lose much time before they accomplish something that should instead be very simple.



  • Keybinds just reset on the patch lol.


Log in to reply