Teleportation [fixed]

  • The problem
    Since the latest patch I am suddenly suffering random teleportation.
    The game will run fine for extended periods of time (> 30 seconds) and then suddenly start acting up and teleport me for a few seconds and then run fine for another extended time interval.
    My teleportation also seems to be observed by other players in the game.
    Below is a youtube video I recorded of the problem:

    I have tried changing some things (both suggested here on this forum and other .ini changes I thought might be even remotely related), but nothing seems to work:

    • The player count on the server seems to be unrelated
    • Sound configuration seems to be unrelated
    • Graphics settings seem to be unrelated
    • Network settings seem to be unrelated

    The diagnostics I ran didn’t seem to have any obvious problems. Except for the game profiler, which seems to point at OnlineSubsystemsSteamworks.GetAchievements being fired in bursts and taking a relatively long time to execute per call.


    Launch log

    Gameplay Profiler

    Any help would be appreciated.

    Update (fixed)
    After many dozens of hours of diagnosing this: I figured out that disabling UPnP on my modem (with built in router) fixes these ping spikes.

  • looks almost like packet loss to the server. If you know the IP of the server you’re connecting too can you ping it via command prompt e.g.

    C:\Users\Monkey>ping -t

    Pinging with 32 bytes of data:
    Reply from bytes=32 time=23ms TTL=119
    Reply from bytes=32 time=24ms TTL=119
    Reply from bytes=32 time=24ms TTL=119
    Reply from bytes=32 time=26ms TTL=119
    Reply from bytes=32 time=25ms TTL=119
    Reply from bytes=32 time=28ms TTL=119

    Ping statistics for
    Packets: Sent = 6, Received = 6, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 23ms, Maximum = 28ms, Average = 25ms

    If you run that for a minute or so (however long it normally takes to lag) do you get any lost packets?

  • Alright I spent several hours again trying to figure this out.

    First off, I pinged the server while I was playing on it.
    This revealed a median ping of 85 ms, with some 800 ms outliers (every 20 seconds).
    There was no packet loss.

    I then decided to install Wireshark and analyze the network traffic further.
    Wireshark also reports no packet drop:
    but every so often the server would send me a UDP packet that had a bad checksum (see the image below).

    Upon further inspection of this one error, it appears to happen a lot.
    The first few communications over (my) port 62163 succeed, but then fails every following frame the server sends to me (see the image below).

    All in all I don’t suspect packet loss or packet drop is to blame though.

    On a side note; due to the ping spikes I suspected MMCSS might be the culprit, but no luck there either.

Log in to reply