Can't join server



  • Ever since patch, chivalry just sits there saying “please wait while the game loads” any time I join a server.

    Actually, it does this on an off, without me changing any settings. I have to keep restarting the game, sometimes 20 times, in order for it to connect to a server.

    This makes no sense at all. Why would it be able to connect some times and not other times?

    Once I make it to the server and start playing, it plays without a hitch.

    Is there any support for this game or what?



  • Does this happen when trying to reconnect to the same server or different servers?

    If different servers the only thing that I can think of that would make one work and one not would be the setup of their ports, in which case have a look at yourfirewall setup?



  • it happens on every server… do any people from torn banner actually come to this tech support forum?



  • @buddha:

    it happens on every server… do any people from torn banner actually come to this tech support forum?

    They answer things they know how to fix.



  • I have this issue upon joining certain servers (not all servers). Maybe around 25% of servers will leave me at the “please wait, loading game” screen until the connection times out. I think it has something to do with ports, firewalls, and possibly your ISP.

    If you’re using a router, try connecting directly to your modem with a LAN cable and see if you that helps. For whatever reason, bypassing my router (which had port forwarding set up to no effect) allowed me to join a few servers which were previously “unjoinable”… Good luck.

    As for the ports to forward: 7777-7779 and 27000-27030 on your router (both TCP and UDP)

    I really wish the devs could fix this. Honestly, I don’t mean to be negative, but joining an online server was never an issue when I played online games 15 years ago. How such a simple, fundamental aspect of an online game could be broken in this day and age is beyond me…


Log in to reply