What graphic options should I disable?



  • Hey guys.
    One day I saw a youtube video (I think it was by HEXEN) which showed that some graphic options are pretty useless and just eat performance without making the game look better.
    But I can’t find the video anymore.

    So can you guys tell me what options I should disable? To be honest, I don’t know what some of the options do. I activate them, fps drops, but I don’t see a difference.

    My fps has dropped since the pre-last patch. So I need to disable something.
    What do you recommend me?



  • The ones I’ve found that eat up fps and response time the most are Depth Of Field, Motion Blur, Bloom, and Dynamic Lights. I’m not going to get into personals, but those seem like the culprits here.



  • @Stinker:

    The ones I’ve found that eat up fps and response time the most are Depth Of Field, Motion Blur, Bloom, and Dynamic Lights. I’m not going to get into personals, but those seem like the culprits here.

    Okay. I guess I’ll turn dynamic lights off and see how it looks like without them. Thanks!



  • I leave dynamic lights on but disable the other things.



  • Turn off ambient occlusion, it doesn’t make the game look that much better so you might as well turn it off.

    Also if you haven’t already go to C:/user/documents/mygames/chivalrymedievalwarfare/udkgame/config/udkengine/ and scroll down to the section called [Engine.Engine] and find bSmoothFrameRate=TRUE and make it FALSE.

    This boosted my FPS dramatically.



  • Yeah, already did that. I checked and my AO is also disabled.
    My framerates are decent nowadays. Used to get worse FPS on certain maps.



  • Since the graphic options menu is heavily bugged I would go to the UDKSystemSettings.ini and work there.

    You can find it in:

    C:\Users\%YOURUSERNAME%\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config
    ```Here are the first 47 lines of mine:
    

    [SystemSettings]
    StaticDecals=True
    DynamicDecals=True
    UnbatchedDecals=True
    DecalCullDistanceScale=1.000000
    DynamicLights=True
    DynamicShadows=True
    LightEnvironmentShadows=True
    CompositeDynamicLights=True
    SHSecondaryLighting=True
    DirectionalLightmaps=True
    MotionBlur=False
    MotionBlurPause=True
    MotionBlurSkinning=1
    DepthOfField=True
    AmbientOcclusion=False
    Bloom=True
    bAllowLightShafts=False
    Distortion=True
    FilteredDistortion=True
    DropParticleDistortion=False
    bAllowDownsampledTranslucency=False
    SpeedTreeLeaves=True
    SpeedTreeFronds=True
    OnlyStreamInTextures=False
    LensFlares=True
    FogVolumes=True
    FloatingPointRenderTargets=True
    OneFrameThreadLag=True
    UseVsync=False
    UpscaleScreenPercentage=True
    Fullscreen=True
    Borderless=False
    AllowOpenGL=False
    AllowRadialBlur=False
    AllowSubsurfaceScattering=True
    AllowImageReflections=True
    AllowImageReflectionShadowing=True
    bAllowSeparateTranslucency=False
    bAllowPostprocessMLAA=False
    bAllowHighQualityMaterials=True
    MaxFilterBlurSampleCount=16
    SkeletalMeshLODBias=0
    ParticleLODBias=0
    FoliageLODBias=0
    SSAOQuality=0
    DetailMode=2

    DepthOfField=False

    DynamicLights=False
    DynamicShadows=False

    Edit:
    @Peculiar:
    
    > Also if you haven't already go to C:/user/documents/mygames/chivalrymedievalwarfare/udkgame/config/udkengine/ and scroll down to the section called [Engine.Engine] and find bSmoothFrameRate=TRUE and make it FALSE.
    > 
    > This boosted my FPS dramatically.
    
    You will find this tip often. It unlocks the framerate but there is no reason why it should increase the performance of your machine. I tested it, and for me the heavily fluctuating fps were unpleasant to my eyes. So IMO leave this on true.


  • One of my many tweak posts but this one is really useful…

    viewtopic.php?f=69&t=17021



  • Turning off dynamic lighting makes a huge difference in the way the game looks so leave that on.



  • Turning off dynamic lighting makes a huge difference in the way the game looks so leave that on.



  • Turning off dynamic lighting makes a huge difference in the way the game looks so leave that on.



  • @fvonb:

    Since the graphic options menu is heavily bugged I would go to the UDKSystemSettings.ini and work there.

    You can find it in:

    C:\Users\%YOURUSERNAME%\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config
    ```Here are the first 47 lines of mine:
    

    [SystemSettings]
    StaticDecals=True
    DynamicDecals=True
    UnbatchedDecals=True
    DecalCullDistanceScale=1.000000
    DynamicLights=True
    DynamicShadows=True
    LightEnvironmentShadows=True
    CompositeDynamicLights=True
    SHSecondaryLighting=True
    DirectionalLightmaps=True
    MotionBlur=False
    MotionBlurPause=True
    MotionBlurSkinning=1
    DepthOfField=True
    AmbientOcclusion=False
    Bloom=True
    bAllowLightShafts=False
    Distortion=True
    FilteredDistortion=True
    DropParticleDistortion=False
    bAllowDownsampledTranslucency=False
    SpeedTreeLeaves=True
    SpeedTreeFronds=True
    OnlyStreamInTextures=False
    LensFlares=True
    FogVolumes=True
    FloatingPointRenderTargets=True
    OneFrameThreadLag=True
    UseVsync=False
    UpscaleScreenPercentage=True
    Fullscreen=True
    Borderless=False
    AllowOpenGL=False
    AllowRadialBlur=False
    AllowSubsurfaceScattering=True
    AllowImageReflections=True
    AllowImageReflectionShadowing=True
    bAllowSeparateTranslucency=False
    bAllowPostprocessMLAA=False
    bAllowHighQualityMaterials=True
    MaxFilterBlurSampleCount=16
    SkeletalMeshLODBias=0
    ParticleLODBias=0
    FoliageLODBias=0
    SSAOQuality=0
    DetailMode=2

    DepthOfField=False

    DynamicLights=False
    DynamicShadows=False

    Edit:
    @Peculiar:
    
    > Also if you haven't already go to C:/user/documents/mygames/chivalrymedievalwarfare/udkgame/config/udkengine/ and scroll down to the section called [Engine.Engine] and find bSmoothFrameRate=TRUE and make it FALSE.
    > 
    > This boosted my FPS dramatically.
    
    You will find this tip often. It unlocks the framerate but there is no reason why it should increase the performance of your machine. I tested it, and for me the heavily fluctuating fps were unpleasant to my eyes. So IMO leave this on true.
    

    Did that now and I’m going to see what it looks like in the game, thank you :)

    EDIT: Insane FPS boost but the game doesn’t look different. O.o But I turned on light shafts, because I just like the way they look.



  • @fvonb:

    Here are the first 47 lines of mine:

    [SystemSettings]
    StaticDecals=True
    DynamicDecals=True
    UnbatchedDecals=True
    DecalCullDistanceScale=1.000000
    DynamicLights=True
    DynamicShadows=True
    LightEnvironmentShadows=True
    CompositeDynamicLights=True
    SHSecondaryLighting=True
    DirectionalLightmaps=True
    MotionBlur=False
    MotionBlurPause=True
    MotionBlurSkinning=1
    DepthOfField=True
    AmbientOcclusion=False
    Bloom=True
    bAllowLightShafts=False
    Distortion=True
    FilteredDistortion=True
    DropParticleDistortion=False
    bAllowDownsampledTranslucency=False
    SpeedTreeLeaves=True
    SpeedTreeFronds=True
    OnlyStreamInTextures=False
    LensFlares=True
    FogVolumes=True
    FloatingPointRenderTargets=True
    OneFrameThreadLag=True
    UseVsync=False
    UpscaleScreenPercentage=True
    Fullscreen=True
    Borderless=False
    AllowOpenGL=False
    AllowRadialBlur=False
    AllowSubsurfaceScattering=True
    AllowImageReflections=True
    AllowImageReflectionShadowing=True
    bAllowSeparateTranslucency=False
    bAllowPostprocessMLAA=False
    bAllowHighQualityMaterials=True
    MaxFilterBlurSampleCount=16
    SkeletalMeshLODBias=0
    ParticleLODBias=0
    FoliageLODBias=0
    SSAOQuality=0
    DetailMode=2
    
    

    Throneroom looks pretty weird with these settings. Almost as if it’s evening instead of daytime. Which by the way, looks pretty cool. A definite boost in FPS though. Personally I would keep dynamic lights and shadows on though. I tried without and it was just weird how players didn’t have shadows.



  • @Peter:

    Insane FPS boost but the game doesn’t look different. O.o But I turned on light shafts, because I just like the way they look.

    Well, if you had high settings before not much changed. The anisotropic filtering is pretty visible if you compare it to before, textures are way sharper even with 2x anisotropic filtering. Glad it works out for you!

    @Jon:

    Throneroom looks pretty weird with these settings. Almost as if it’s evening instead of daytime. Which by the way, looks pretty cool. A definite boost in FPS though. Personally I would keep dynamic lights and shadows on though. I tried without and it was just weird how players didn’t have shadows.

    Hey, then you didn’t copy my “47 lines”, because there DynamicLights and DynamicShadows are set to true. Below I wrote what I would change next if that is not running smooth enough. Most levels look extremely different without DynamicLights, like you said, it looks like they are set in the evening.


Log in to reply