[SOLVED] UDK.exe crashes, tested Giant solution list



  • Hey,

    I have a lot of trouble making this game working…

    When I want to create a game, join a game, or start a training session from the game menu, the game crashes by saying “UDK.exe has stopped working”.

    I tried everything from the “Giant solution list” and other things found on this forum: reinstalled the game (multiple times, on different drives), updated my graphic drivers, starting the game directly from UDK.exe, tried running both steam and the game as administrator, running the game in XP SP3 compatibility mode, reinstalled DirectX, reinstalled Visual C++ 2010, deleted the chivalry folder in “My documents > My Games”, verified steam cache integrity. Nothing works.

    http://www.canirunit.com says my hardware passes the minimum requirements: I have an Intel Core 2 Quad Q6600 (4 cores at 2.4Ghz), 4Go of RAM, an AMD Radeon HD 7700 graphic card, running Windows 7 64 bits.

    Attached are my DxDiag and Launch.log files.

    Thanks in advance for the help,
    Leimi

    EDIT: FIXED IT!
    I had put a “-nomovie” disturbing option in the game “launch option” in Steam. Removing it solved the issue! Put it there one time to test things and forgot about it and totally didn’t think that could be the cause of having the game to crash…



  • I can see the (filename not found) [in C:\Program Files\SteamLibrary\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe] errors in the launch log. Firstly just wanted to double check that that path exists (sometimes things get a big shuffled around).

    Likewise to check the \UDKGame\CookedPCServer where the game is trying to load the map files from also exists.

    I know you said you’ve tried deleting the chiv folder in documents and verifying the game cache but was it in that order (delete the chiv folder in documents first then verify the game cache?)



  • Okayyy so I don’t know if it’s the latest patch or what, but the game now works if I start it directly from UDK.exe (something I tried dozens of times before)!

    Yayyyyy, hoping it’ll stay like this!



  • Well, maybe I was happy too fast on this one…

    It appears than when I launch the game directly via UDK.exe, I can’t see any server at all or play with my Steam friends. I basically only can create a game with bots or play the tutorial.

    If I start the game via Steam, I see servers and all, but as soon as I try to enter a game, or create one, or play the tutorial, it crashes just as described in the first post.

    Any idea? And btw, I indeed deleted the chiv folder/verified game cache, in that order.

    Thanks,
    Leimi



  • OK, I FIXED IT!

    In the Chivalry launch options in Steam, I had a “-nomovie”. I deleted it and hooray: the game now works via Steam and I see servers and all. Go figure!

    I must have added that -nomovie really early when I tested things a while ago (when I had a different CPU that seemed incompatible with the game in the end).
    I totally forgot about this launch option. It’s kind of a shame for this case that Steam keeps this options in memory even when you uninstall/reinstall the game. So I totally forgot about it and in fact totally thought I had no “launch options” set at all in the end after multiple remove/install processes.


Log in to reply