My Bug Report on Deadliest Warrior



  • So far I’ve really been enjoying the Deadliest Warrior Beta. I tested it so far on my older setup: an 8800GT 512MB/e6850 Core 2 Duo on Windows XP 32bit and I ran into a few issues.

    I loaded up the game in windowed mode the first time, and was able to jump into a game from the console without much issue. Played the game on low settings but surprisingly high framerate (Solid 60 FPS). Moving it up to medium and high texture/character settings didn’t make much issue. Until…

    Performance Issue 1) Shadow/Detail Mode issue?:
    When I changed some shadow/detail mode settings, my frame rate nose dived to 5 FPS. Normally that wouldn’t be an issue, I’d just revert the settings back. However, reverting them back did nothing. Even on the lowest settings, the game stayed at 5 - 10 FPS and I was forced to restart. After that it worked fine. Not sure what was up with that. I tried changing those settings again and then they worked okay, just lost a few frames. So I can’t recreate the bug.

    Performance Issue 2) Windowed mode weirdness (Part 1):
    The game loaded in window mode the first time without a hitch, and I was able to play some matches in Last Team Standing. After LTS changed to Acropolis, I got a crash. Then after that every time I tried to join Acropolis I got a “Not Enough Video Memory…Exiting.” Error every time I tried to join the game. Putting it on the lowest setting for everything didnt fix it.

    Slygoat changed the stage to another one (the bamboo/samurai one) that had worked for me before but that error message popped up no matter what. Then after the game loaded in window mode and I was entering the map through console, I tried to fullscreen the game as it loaded the map. Doing that allowed the game to load the map. However before that it was giving me video memory crashes every time. Not sure what caused that, but it seems like it might be worth checking out.

    Performance Issue 3) Windowed Mode Weirdness (Part 2): Serious Bug Edition):

    After the main testing was done, I wanted to do some training, so I closed the game and reopened it. Then I got a really bad issue where I couldn’t open the game at all. It tried to load into fullscreen mode and would instantly crash. It would give me either ALPHA.exe crashes, kernel32.exe crashes, a silent crash, or video mem crashes (like the one I mentioned before.

    So I had to put in an “-windowed” flag in the steam startup for the game. That was the ONLY way I could get the game to boot anymore. So I went into training mode, messed around a bit, (training mode is great by the way) and then decided to try to put the game into fullscreen with Alt+ enter.

    The game then entered an infinite loop where it would try to go fullscreen, then it would forcefully go back to windowed mode, and then it would lock out all other inputs. I couldn’t alt tab, I couldn’t alt+f4, all I could do is watch it go into this infinite window mode/fullscreen mode loop.

    Ctrl Alt + Delete Worked, but when I brought up task manager, it wouldn’t switch to task manager. It would just loop infinitely as it took precedence. I tried logging off, but that didn’t work either. I was forced to hard reset my PC in order to exit that mode. After that, I decided not to play the game for a while. That was probably the biggest bug I noticed.

    Performance Issue 4) Pre-match UI problem:

    I dont think the prematch UI (the one that tracks your stats and tells you your nemesis/etc) is scaled to the resolution of the screen. I played at 800x600 resolution on fullscreen and windowed, and as long as that window popped up I couldn’t do anything. It was just zoomed in on a section where I couldn’t select any options nor could I close the window or get out of it.

    A simple command to close it would be great (Esc/M for example) but even better would be for it to scale to your screen’s resolution. As it is right now, it’s a static image…a large one at that, and I could only get around it by reloading the map through the console.

    Now for Gameplay Bugs!

    Gameplay Bug 1) Venus Flytrap House Corners:

    On the Viking/Norse map with the pier, and the many houses, fences, etc. The corners of a lot of the houses on the map are deadly. If you get too close to them they grab onto you and hold you indefinitely. I’ve died many times just walking too close to the house. Other people have had this issue as well, so I feel it’s worth nothing

    Gameplay Bug 2) Bubble Prevents Shield Bashing From Hitting:

    I played Spartan a lot during my beta test time, and I was having a blast with the character. The Spear Feels great, and I like how many different combinations they have. Plus the shield being a legitimate attack is a very interesting move to use.

    However, I ran into a consistent issue with the bubble around characters with hitting the shield bash on targets. Whenever I used the shield bash, and I was sure I would hit, I would find myself missing it a LOT. People would be right in my tracer range, and just get pushed away, and never get hit.

    I’ve hit perhaps…10% of all the shield bashes that I was sure I hit. Not due to incorrect placement, but just because it would miss at ranges where it should hit, due to the bubble. In gameplay, it’s just really frustrating as I would be leaving myself entirely open to a counter at that point, and losing stamina for an attack that I was confident in.

    I had similar issues with the ninja’s fist claws as well. The bubble just messes up a lot of parts of the combat that should be flawless.

    Gameplay Bug 3) Spartan Spear hits too far behind them:

    I had an issue where spartan spears hit behind them a little bit too far. Since the tracers start at the very end of the spear, you have a tendency to hit walls, and other objects behind you when starting up the attack. This is beneficial in open fields and allows some classic Chivalry silliness to occur(turn around stabs and stuff like that), but in a close quarters situation, it’s a huge hindrance.

    Imagine for example, you’re fighting an enemy in a closed spaced, like a corridor, and he has shield. You have a spear, and you want to poke around his shield. So naturally you have to rotate around him left or right in the corridor to access his sides. In doing so, my spear gets “stuck” into the wall. Then, when I attack to spear starts its windup, and then enters the release. But the release loads its tracers IN the wall, which makes me hit the wall behind me, and leaves me entirely open to attack.

    This is more of a personal pet peeve, as I’m sure there would be useful applications for it having such a long tracer, and alternatively I COULD just switch to my side arm. But I still wanted to put that out there as a potential downside to the long tracer.

    Overall though I really enjoy C:DW more than the current version of Chivalry in fact. It feels really polished, diverse and fun. All the new classes feel like their respective groups and a lot of the weirdness that I’m used to in Chivalry isn’t that effective in this iteration which is a huge plus, and this is coming from someone who drags, looks down overheads, and all that. I really like this version of the game and the direction it’s taking a ton.

    Just…please get rid of that bubble.

    I’ll give more detailed feedback later.


Log in to reply