FPS issues



  • Hello fellow Chivalry players. I have been troubling with some FPS issues regarding the new DLC Deadliest Warrior. I recently found out that the issue is both for the DLC, and for the original Medieval Warfare game. Unfortunately I have not found any “good” answer on my problems, therefore I write this to ask the community.
    My PC reaches the minimum requirements for playing Chivalry, and even more:
    Processor: Intel Core i5 2410M @ 2.30GHz
    GPU: nVidia GeForce GTX 460M
    RAM: 4 Gb RAM
    HDD: 500 Gb (Just to mention)

    When I choose High Performance mode on my PC combined with the lowest set of graphic quality in-game, I was rather shocked when I fell down to a 20 FPS on a regular 20 Player Team Deathmatch server.

    I have literally tried everything there is to try to fix this problem. Several people have tried to help me over TeamViewer, the nVidia control panel has been edited to support performance instead of quality in the game, and generally. I have stopped and closed several start-up and processes to make the PC even faster, but nothing helps. I got decent internet connection with a good PING. Therefore I wonder why I cant run Chivalry smoothly.

    Does it have something to do with the game being in BETA, do the BETA support my nVidia GPU? Is there something more I can do to get better FPS?

    Thank you for reading and hopefully answering.



  • Sigh. Here we go….

    Okay, so after the latest patch I noticed my FPS to be SIGNIFICANTLY lower. I used to get a constant 62 fps…now it’s 35-40 and dips into the high 20’s on really crowded maps…WTF TBS

    My specs are as follows:

    GPU: AMD 7870 2gb
    CPU: AMD FX-8350
    RAM: 8gb

    This is a pretty good setup, so it’s beyond me why I’m having issues all of a sudden. I other games that are WAY more graphics intensive than chiv at higher fps. TBS, plz fix this if it’s your problem…it’s SO bad.



  • I get fps drop after EVERY patch. They say it will clear up some days after the patch… It never cleared up for me :/


  • Mod

    I had this happening to me on the patch they introduced citadel and the new weapons. I’ve deleted everything (except the things in the my games folder) and reinstalled and it solved it for me.

    I have an Intel Core i7 960 with an Nvidia GTX 550 TI and 18 gb DDR3 1600hz RAM.

    Try reinstall?


  • Mod

    Moved your posts to the appropriate forum.



  • But But…his is about DW :(

    And too be honest, his hardware kinda sucks, no offense. :|


Log in to reply