UPDATE! 12/6/13 Getting 90-200 FPS with these INIs



  • UPDATE 12/6: I have tested this config and I am still getting very high FPS. I am getting around 200 with a 4.5ms per frame at the Main game menu. However, There also appears to be an issue with the copy/paste function on the forums. Make sure that if you are copying from the forums that there are no added spaces in areas of the config command text when you post. For me there was an added space after every 50th character after the paste into the ini file. Thus after a paste go through the ini settings and remove any extra added spaces and it works fine.

    Uploaded links to both downloadable UDKEngine.ini and UDKSystemsettings.ini
    http://rhinoceg.com/orangebox/ageofchivalry/UDKEngine.ini
    http://rhinoceg.com/orangebox/ageofchivalry/UDKSystemSettings.ini

    Ok now that I have retweaked after the patch, I found a few more that I have implemented that I am having great results with. I am still getting some micro stuttering and have yet to find the best fix.

    Currently I am getting 200FPS at main menu and solid 90FPS on most maps with 24 players with a resolution of 1200x800. This is on a Quad Core Duo 2500 OC to 3000, 6 gigs of ram and a GTX560 TI

    So I am posting both my UDKEngine.ini and my UDKSystemSettings.ini. These are here for you to test. If you don’t know what you are doing then don’t try these. As always, I will continue to work on improving the games playability. Let me know if these settings help you.

    Instructions:
    Test your games FPS by typing STAT FPS in console, pic a map and watch your FPS. Then quit the game and follow the instructions below

    1. goto My Documents/My Games/Chivalry Medieval Warfare/UDKGame/Config
    2. Make sure you make a backup of your original files.
    3. Open your your versions of these files in Notepad
    4. Copy and paste my versions and hit save.
    5. Test them out.

    UDKEngine.INI
    http://rhinoceg.com/orangebox/ageofchivalry/UDKEngine.ini
    **
    UDKSystemSettings.ini**
    http://rhinoceg.com/orangebox/ageofchivalry/UDKSystemSettings.ini



  • Posted links above



  • Update: I have been testing in game settings to make the game look better without costing FPS with those INIs installed. I can have Ambient Occllusion ON, Depth of Field ON and Particles on HIGH with little to no cost in FPS and makes the game look much better!

    Now inside the INIs most of the shadows have been either turned off or way down so dynamic lighting and dynamic shadows even when turned ON do little graphically but still have a big FPS drop.

    Feel free to test other in game settings and post up



  • I still think the optimal solution would be for AMD and Nvidia to optimize their drivers for this game, they do so for many others; why not Chiv!? However… this is out of our control.



  • @gref:

    I still think the optimal solution would be for AMD and Nvidia to optimize their drivers for this game, they do so for many others; why not Chiv!? However… this is out of our control.[/quot]That is really the issue if the game is poorly optimized to begin with. One of the many settings I tweaked was the texture resolutions of player models. By default it is at level 3, by turning it down to 1 saves a ton of texture CPU drain per player model specially on a full server.

    The maps are far worse design wise with gaps and overlaps with meshes and textures and lots of stuff being rendered that you will rarely or never see from a players perspective. No driver optimization can fix a bad game.



  • My issue is not that Chivalry is using my resources inefficiently (even though it does), it’s just not using the resources at all!
    CPU frame times are fine usually < 15ms, it’s the GPU utilization that’s awful.
    GPU frame times jump between 20ms and 40ms on the worst maps.
    -With one card GPU usage is usually less than 70%.
    -With two cards GPU usage is usually less than 20% on each card.
    I’ve talked to people with Nvidia cards and SLI, it’s no better. Nvidia does not have a driver profile for Chiv either.
    Chivalry refuses to use more resources to make more frames. Torn Banner needs to work with AMD and Nvidia to optimize resource allocation.

    There are no-name games out there with driver profiles from both companies. Chivalry is a successful game and I couldn’t picture Nvidia or AMD turning them down. My guess is TB HASN’T EVEN TRIED to talk to either company.



  • @gref:

    My issue is not that Chivalry is using my resources inefficiently (even though it does), it’s just not using the resources at all!
    CPU frame times are fine usually < 15ms, it’s the GPU utilization that’s awful.
    GPU frame times jump between 20ms and 40ms on the worst maps.
    -With one card GPU usage is usually less than 70%.
    -With two cards GPU usage is usually less than 20% on each card.
    I’ve talked to people with Nvidia cards and SLI, it’s no better. Nvidia does not have a driver profile for Chiv either.
    Chivalry refuses to use more resources to make more frames. Torn Banner needs to work with AMD and Nvidia to optimize resource allocation.

    There are no-name games out there with driver profiles from both companies. Chivalry is a successful game and I couldn’t picture Nvidia or AMD turning them down. My guess is TB HASN’T EVEN TRIED to talk to either company.

    Well it might not be TBs fault but more of not enough players with NVidia cards bitching… I know right? Besides I am not even sure how to go about getting Nvidia involved. Guess I will get on their forums and ask.



  • Update! I solved the issue with these INI not working. The paste function was adding a space after the 50th charactor. Thus some of the INI setting strings are quite long and there were added spaces. Other than that I repaired and made some changes to the thread to fix readability. I will try and do a combo INI between this thread and my big one I posted with explanations.



  • Can you upload your files? There is A LOT of spaces to remove.



  • @SirSamba:

    Can you upload your files? There is A LOT of spaces to remove.

    DONE! Check links in the first post!
    Sadly the attachment button only works for a web link and not a direct upload. If you copy/past into notepad, it really isnt that many since the space is added ever 50th character. Use your delete then arrow down key and it only a min or so. Hopefully the MOds will get their shit together and fix both issues of copy/paste and the attachments.



  • Oh man, Retsom thank you!
    I’ll be trying this out over the weekend. You’re awesome!



  • I tried these INI tweaks and they work really well. I am getting much better and smoother game play thanks to these.



  • yep, can confirm they works well, several clan members use them :)



  • Glad to be of service but it looks like I will no longer be doing tech support since my original account got perma banned. So much for the ultimate tweak post I was working on….



  • What the hell man? Why would they ban you from the forums? Everything I have read thus far, you have gone out of your way to help all those that have mid range computers like mine. I had a few more questions to ask you. What the hell is wrong with the developers and the moderators on this forum? It seems quite obvious, reading all these complain threads, there are few solutions and the one guy that actually helps, gets banned? Good god what did he do that was so terrible and offensive? I haven’t seen it. No wonder there are so many complaints threads about this game and even the community.



  • Why was he banned? :frown:



  • Because he was always fighting with lemon.

    Not much forethought put into the ban really seeing as how much work and effort Retsnom has put in to the betterment of this game.



  • @DokB:

    Because he was always fighting with lemon. Not much forethought put into the ban really seeing as how much work and effort Retsnom has put in to the betterment of this game.

    So why wasn’t lemon perma banned as well. I dont know of anyone that actually likes the guy. He might have one or two guys agreeing with him on occasion but he is far from helpful. Besides, have you read his worthless posts? At least Retsnom posts were extremely helpful and informative to so many people in the tech support side along with some game mechanic explanations. What the hell has Lemon contributed to? Looks like they banned his other account as well. How sad……



  • I don’t know? Ask a mod.

    I don’t think either were deserving of a ban to be honest. The fight had to stop though, it was getting out of hand. Went on for months where both were just disagreeing with each other. It wasn’t about who was correct in the end, it was just the constant back and forth between them. Retsnom probably shouldn’t have lost it so many times and Lemon probably shouldn’t have baited him so much.

    Mod’s won’t see it as who contributed more to the community, their jobs are to make sure the forum rules are followed. Again, I don’t think a perma ban was necessary, I think perhaps maybe they should have just avoided each other via the ignore list.

    But hey, I’m not the mod here.



  • There were several posts that drew the attention of mods and devs, I believe Retsnom was warned by mods/kimi on a number of occasions and then was temp banned a few times with a warning of a future perms ban. since every other method was eventually exhausted, that’s what ultimately happened.


Log in to reply