Connection to the Host Has Been Lost



  • I have a lot of servers running with no issues except for a small port conflict problem that crops up from time to time. Recently a new server was setup and the port conflict issue was fixed. After restarting the server TCAdmin and query scripts all say it’s online. I can’t see it in the server list and am trying to connect via console command. Everytime I try to connect I get thrown back to the menu with an error stating “Your connection to the host has been lost”.

    I tried reinstalling the server, changing all of the ports, and turning on logging. So far nothing has helped. Here’s the end of the log file where I get disconnected:

    [0876.04] NetComeGo: Open TheWorld 10/30/13 14:55:36 23.25.84.174
    [0876.34] Error: Received unknown control channel message
    [0876.34] NetComeGo: Close IpNetDriverSteamworks_1 IpNetConnectionSteamworks_4 23.25.84.174:50086 10/30/13 14:55:36
    [0876.40] NetComeGo: Open TheWorld 10/30/13 14:55:36 23.25.84.174
    [1101.25] NetComeGo: Close IpNetDriverSteamworks_1 IpNetConnectionSteamworks_5 23.25.84.174:50086 10/30/13 14:59:21

    Has anyone had this problem? I’m not sure what to do about it since even reinstalling on new ports doesn’t help.

    EDIT: I also forgot to mention, I also tried restarting my PC on the off chance Steam was to blame.



  • I updated the server, not sure how I missed it this time. I have more info but I still don’t understand it. TCPView shows the query port but not the server/connect or server+port. It for whatever reason no longer queries and is basically completely broken. I’m going to completely remove the folder and start from the beginning and see what I get.



  • I moved the TCAdmin account to another server and the issue persisted. I downloaded a fresh copy of CMW from steamcmd and modified the configs and it seems to be working now. My best guess is updating the game files even with validate set isn’t working correctly. I’m going to use this new fresh copy as my TCAdmin setup file and hope the next server is problem free. I’ll setup a test server later to be sure.


Log in to reply