Can you re-map console key?



  • Playing on a Macbook with Windows 7 bootcamped, for some reason console key is ’ now instead of ~. It’s really frustrating trying to type with it.



  • how the fuck are you playing on a macbook, you must get like 2 fps.



  • @clayton-bigsby:

    how the fuck are you playing on a macbook, you must get like 2 fps.

    Depends on the MacBook. Some come with dedicated graphics and large CPUs.



  • @lemonater47:

    @clayton-bigsby:

    how the fuck are you playing on a macbook, you must get like 2 fps.

    Depends on the MacBook. Some come with dedicated graphics and large CPUs.

    yeah if he paid like 2k+ for the damn thing… and even the ‘dedicated’ graphics are obvoiusly still onboard graphics… so heat is always an issue there. I digress.

    To answer, I just did a little google search and it looks like you may be able to do the rebind in the console.

    setbind [key] toggleconsole

    or

    it might be bind [key] toggleconsole.

    May be in the config file too for keybinds if you can look up the ~ key and rebind it. I can’t look right now because at work.



  • You can remap the console key
    C:\Users*your user*\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKInput.ini

    ConsoleKey=Tilde

    I changed it to

    ConsoleKey=F12



  • arr she blows



  • The Mac was paid for by financial aid for school, I didn’t pay anything for it and it has a pretty powerful nVidia card on it. I can play Chivalry on max settings at almost 60 FPS constantly, 1440x900 resolution. It’s much much better than my old laptop, which barely ran 5 FPS on ideal environments on lowest settings and 1024x768 resolution lol. The Mac keyboard however… is trash. It has two keys called fn and command, right where ctrl and alt should be and you can’t bind stuff to them. Very hard to re-learn where to position your fingers for them. Also to prt scrn you need to do something like hold shift, fn and press F11, and for window prt scrn you gotta’ hold alt too. Lots of weird crap. No insert or delete, so I had to bind vote yes and no to period and comma. To respawn with F1, I have to hold fn then press F1 which is very hard to do in those intense moments sometimes.

    It also only has 2 USB slots, so I’m saving up for a USB hub and a USB keyboard ASAP. It’s way more powerful than my old laptop, though.

    Anyway, setbind ` toggleconsole doesn’t work, it says ‘SetBind’: Bad or missing property ‘BindName’ and the UDKInput says it’s already on tilda, when it’s on apostrophe. When I type in like setbind leftbracket toggleconsole it does nothing as well.



  • Yeah mac keyboards are weird with their buttons. I do like the fact that you can just slide over the keyboard as all the keys are very low. 2mm above the base of the keyboard.


Log in to reply