Recooking under the same GUID



  • I’ve got really weird and irritating problem. I made an update to my map file and now want to cook it under the same GUID, but whenever I try that it seems to be cooking older version which I don’t even have. How is that possible?! I unsubscribed from my map, removed the files downloaded by Workshop and it didn’t help. It somehow keeps cooking the old version.

    When I cook with a fresh GUID it works properly, the map is updated, however I’d like to update my Workshop entry not create entirely new one every time I want to upload new map version. Also when I move the correctly cooked map to the folder with original GUID and load it in game the old version which I don’t even have on my disk anymore is being loaded. How…? What is this foul sorcery?



  • I’m certainly not the most qualified person here to help you, but maybe we can figure it out together.

    After cooking with a new GUID, did you try making a small change and recooking under the new GUID again to see if the problem still exists?

    @Ferum:

    Also when I move the correctly cooked map to the folder with original GUID and load it in game the old version which I don’t even have on my disk anymore is being loaded.

    I don’t see this method working too well, but I probably would’ve given it a shot as well.

    It’s worth a check to make sure all of the required batch/text files are configured properly since after doing it a few times it can be easy to overlook.

    For example, the text file within “CookedSDK/__CMWSDKFiles” that points to your GUID in the top row (Packagedirectory). Updating this after cooking several things could be easily forgotten and could cause a similar situation to what you are experiencing.

    Double check “SDK - UPLOAD TO WORKSHOP” as well, and make sure this batch file does indeed point to the correct text file, and not that of your previous version.

    Finally, the originally named “SDK - COOK” should find the updated version of your map so check that “Modname=” still shows the correct map name, and that the -GUID= at the end of that line is updated. Copy/edit/rename a new SDK - COOK for each seperate cook so that you won’t have to change them again.

    Basic stuff to check, obvious enough…but still sounds like your problem lies somewhere in this direction seeing as the hard part is over. I have no idea where you stand so if reading this is making you dumber I apologize. Feel free to add me on steam, I think those working with the SDK should stay connected so that we can all help each other learn and make better maps.

    EDIT: I guess I could put some effort into my posts



  • Hey mate, I was having the same problem myself. Dunno if you’ve fixed it yet, but what I did was First, make sure you’re not subscribed to your map, Second, delete the AOCSdk level with your guid in it, in the __CMWSDKFiles folder. Third, I deleted everything in the AOCSDKLevels_yourguidhere, expect cooker files. Then i tried cooking the map, then wala everything worked. Hope it works for someone else having these troubles



  • Thanks a lot for your help guys! I will give it a shot today and try to get it working. I will let you know about the outcome.



  • So it magically fixed itself! Foul sorcery, indeed. After resubscribing to my map I removed it again (the file in CMWSDKFiles), checked if all names and IDs are corrrect, cooked it and apparently it works now.

    Thank you seriouscasual and silentwalker for your help again!



  • Glad it worked mate! I feel helpful now haha :D


Log in to reply