Very high ping



  • Hey I’ve played the game since release without any problems and have had a break and decided to start playng again but now on every since server I have around 300-400 ping!

    I do not download while playing.

    I’m from Sweden so servers shouldn’t be a problem.

    GTX 580
    i5 2500
    8 gig ram



  • A constantly high ping does suggest a background process streaming…

    To my personal experience I noticed that for some reason Chivalry isn’t always classified as a ‘game’ on my PC and some programs(even Windows) will still update while the game is active.

    I fixed most of my problems my going to Start -> Type ‘Services’ and open that. In this screen you can just shutdown EVERYTHING you don’t need for gaming. (Not kidding, don’t just stop the daemon tools, but also like the printer save-for-later function, a random photo viewer service etc.)
    If this fixed your lag, next time you get the same issue apply this fix again but this time also set each unnecessary process’ startup condition to “disabled”. This will prevent them from running under any circumstances. (And no, so far I haven’t encountered a single error with this, so don’t worry about shutting down your entire computer by accident or anything like that)

    If this doesn’t work, walk upstairs/downstairs, pull your little brother off his computer and then cancel all the 1080p porn he is downloading for when 480p doesn’t quite cut it.



  • @Rickvs:

    If this doesn’t work, walk upstairs/downstairs, pull your little brother off his computer and then cancel all the 1080p porn he is downloading for when 480p doesn’t quite cut it.

    Oh my god…I am crying…my cheeks, they hurt so bad…


Log in to reply