Getting duel mode to work



  • Howdy. I’m trying to get duel mode working on my map (Fourcorners), and I’m running into this issue where I can’t actually spawn. When I try to run the map from the editor it gives me the message “Couldn’t spawn player: Could not find a starting spot”. If I try running it from the game itself it’s like it doesn’t recognise it as a Chivalry map, it just spawns me as the default camera thing you get when you make a new map without setting any spawns or setting the game type.

    It’s odd, because I had issues when I was trying to get spawns working in the early stages of making the map, but I could still play in the editor even if spawns weren’t actually working.

    I have two AOCDuelPlayerStart actors (one set to Mason and the other to Agatha), an AOCPlayerStart actor used as the level loading camera, and an AOCDuelCameraActor, which seems to be exactly how it’s set up in the example duel map. And I also have the world properties set up the same as the example map.

    Am I missing something? Is there something else I need to add or change? Do I need to play with Kismet at all?

    Here are some screenshots (imgur album: http://imgur.com/a/uiQzu):



  • Dunno much about Duel mode, but have you tried setting the AOCDuelPlayerStart actors to ‘all’ instead of mason and agatha?



  • @silentwalker:

    Dunno much about Duel mode, but have you tried setting the AOCDuelPlayerStart actors to ‘all’ instead of mason and agatha?

    Didn’t work. When you hover over “Duel Zone ID” box in the duel actor properties window it says you need at least one Mason and one Agatha spawn to make a valid duel map.



  • Hmm thats weird, I opened up the Duel example map, and none had a mason or agatha faction, they were set to all. And there’s no kismet code in it either

    edit: and then i opened the other example, and they were to set mason and agatha. I have no clue what to think anymore. You’ve built paths right? prolly a stupid question



  • @silentwalker:

    You’ve built paths right? prolly a stupid question

    Haha, that wasn’t a stupid question, I’d forgotten to build paths. I just did a quick build all and it worked. I knew it must’ve been something dumb like that… -_-



  • Haha glad ya fixed it mate! If there was a list of stupid things i’ve done in udk tryin to learn how it works… it’d prolly be about 20 pages long… and growing


Log in to reply