Question regarding Multi-Servers under 1 IP.



  • I have 4 servers running under 1 IP; these servers run ok and have people in them but from time to time, they return no info and don’t show on the list.
    Must i change all the ports to a dedicated value in the udk and cdw engine.ini file???

    Line 12: Port=7778
    Line 13: PeerPort=7779
    Line 424: ServerBeaconPort=8777
    Line 425: BeaconPort=9777
    Line 568: ListenPort=13000
    Line 620: SystemLinkPort=14000
    Line 620: SystemLinkPort=14000



  • I don’t see the QueryPort in there mate.



  • @Raizio:

    I don’t see the QueryPort in there mate.

    Qport: determined in my command line for each…

    now, i could be wrong but there is a qport in this:

    [OnlineSubsystemSteamworks.OnlineSubsystemSteamworks]
    QueryPort=24038



  • @Kahne:

    @Raizio:

    I don’t see the QueryPort in there mate.

    Qport: determined in my command line for each…

    now, i could be wrong but there is a qport in this:

    [OnlineSubsystemSteamworks.OnlineSubsystemSteamworks]
    QueryPort=24038

    That is indeed the one I was talking about.

    As you said, every server needs a different set of ports;
    Use TCPView to check if all the ports are actually bound/made by UDK.exe/Windows(or Linux)



  • @Raizio:

    @Kahne:

    @Raizio:

    I don’t see the QueryPort in there mate.

    Qport: determined in my command line for each…

    now, i could be wrong but there is a qport in this:

    [OnlineSubsystemSteamworks.OnlineSubsystemSteamworks]
    QueryPort=24038

    That is indeed the one I was talking about.

    As you said, every server needs a different set of ports;
    Use TCPView to check if all the ports are actually bound/made by UDK.exe/Windows(or Linux)

    OKay, So does does the Qport in the command line and the Qport in the engine file need to be the same?



  • I think commandline overrides config, but you can put them the same to be sure.


Log in to reply