[CMW] Keybinds STILL DONT SAVE



  • I’ve been posting and telling the ‘admins’ ingame about this for about 3 months now….

    CHANGING THE SECONDARY AND TERTIARY ATTACK KEYBINDS STILL DO NOT SAVE

    I use the side mouse buttons for secondary and tertiary attacks, not the mouse scroll, and for the past 3 or so months I’ve had to rebind them every single time I load up the game.

    I also have to UNBIND the alt attacks from the side mouse buttons because they start conflicting with the new keybinds to the ones I (shouldn’t) have to reconfigure every single time.



  • Bump, because it still doesn’t work…



  • Bump, still not fixed



  • Bump, fix the rank and weapon unlock bugs please.



  • There is a trick to making it stick if it is not doing it in game. First run the game and make all your keybinds then test it in game. Once you are satisfied that they are how you want them. ALT-TAB out of game and go to your config files located at C:…My Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config. Now what you want to do is to right click onto the UDKGame.ini and choose properties. Then under Attributes, put a check in the box that says READ ONLY. This will stop Chiv from writing over the INI file when the game closes and it can only read it when the game launches. make a back up copy so that when the game is updated, you can just swap that file.



  • Thanks for the suggestion Retsnom, but UDKGame is already set to Read Only, and my keybinds are still reset every time I launch chiv.

    Of course this isn’t being fixed in the upcoming patch, according to the patch notes.

    BUMP



  • New patch came out, still not fixed. Bump.



  • New patch came out, still not fixed. Bump.



  • Another patch, and my past is still ignored, along with plenty of others having the same problem. 3 months plus and counting now.



  • I’m so confused. I remember this thread being about the rank and weapon unlock bugs. How did you change the thread title?



  • @Flippy:

    I’m so confused. I remember this thread being about the rank and weapon unlock bugs. How did you change the thread title?

    You’re dreadfully confused. Read the original post. Not sure what you were talking about when you replied, but your earlier comment is true nonetheless.



  • @bootyhorn:

    Thanks for the suggestion Retsnom, but UDKGame is already set to Read Only, and my keybinds are still reset every time I launch chiv.

    Of course this isn’t being fixed in the upcoming patch, according to the patch notes.

    BUMP

    This may sound dumb but are you sure you have the right location and the right UDKGame.ini? It should be located C:\Users\……\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKGame.ini

    The trick is to make the changes in game with all of your keybinds then while still in game, ALT +TAB out of game and then set it to read only. Then exit the game. When you relaunch it it should just read the UDKGame.ini that you last used. IF you set it to read only after you have closed the game, the game can sometimes rewrite the INI back to default upon closing the game. Thus if set it to read only after closing the game you have locked in the default settings.



  • @Retsnom:

    This may sound dumb but are you sure you have the right location and the right UDKGame.ini? It should be located C:\Users\……\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKGame.ini

    The trick is to make the changes in game with all of your keybinds then while still in game, ALT +TAB out of game and then set it to read only. Then exit the game. When you relaunch it it should just read the UDKGame.ini that you last used. IF you set it to read only after you have closed the game, the game can sometimes rewrite the INI back to default upon closing the game. Thus if set it to read only after closing the game you have locked in the default settings.

    I appreciate the help, it’s a shame TBS can’t fix their own bugs, but I did exactly as you suggested and still no luck.

    Bump.



  • Well, I can see that I’m not the only one with a keybind problem. Mine won’t reset in the window for them, guess I’ll have to go into the .ini files.



  • Another new patch, still no fix. 5 months and counting on this thread, bump.



  • Another new patch, still no fix. 6 months and counting on this thread, bump.



  • Another new patch, still no fix. Bump.



  • Gonna keep bumping this…have tried the suggestions given to me and still no luck.



  • 7 months and no fix - not even a response. Bump.



  • I think the lack of responses are possibly down to people have no idea how to fix this issue - it’s not one that we see that often.

    If you check the modified time on udkgame.ini in the ……\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\udkgame.ini then launch the game, edit some keybinds, does the modified time change?

    What happens if you try to set a bind from the console e.g. setbind o say testing
    or something like it, does the line get added to that ini?

    Also to check whether the file is read-only and are you running the game with sufficient permission to write to the configs? Maybe try launching it directly from the executable and run as administrator?


Log in to reply