Failed to bind to interface, IP_DONTFRAGMENT on chivalryserver running with wine



  • After starting the server using wine, it runs fine for a few hours. But after some time these two errors start to appear:

    fixme:winsock:WS_setsockopt IP_DONTFRAGMENT is silently ignored!
    err:winsock:interface_bind Failed to bind to interface, receiving broadcast packets will not work on socket 0690.
    ```and the server is no longer reachable/listed in the lobby. I've read that it might have to do with blocked ports, but I made sure all needed ports are unblocked. Server is running on ubuntu 12.04 64bit with wine-1.6\. Any hints and help are appreciated.


  • What NIC do you have it bound to? Are you using multihome on the command line if you have multiple NIC setup (or virtual NICs in the way of emulation)?



  • @MonkeyFiend:

    What NIC do you have it bound to? Are you using multihome on the command line if you have multiple NIC setup (or virtual NICs in the way of emulation)?

    eth0. No virtual nics and no multihome. It works for a few hours, you can play on it etc.



  • ok, not officially supported obviously. What sort of info do you get if you run debug in wine? Assume aside from ports being open, the port forwarding is set up correctly?



  • I’m trying a newer wine version right now ( 1.7.8 ) and check if it works. I’m not sure what you mean with running debug in wine. Also, if the ports were set up wrong it wouldn’t work from the start and not just stop working after a few hours, or am I wrong?



  • I’m using win 1.7.33 (32 bit) compiled from source on a 64 bit machine. Now THAT was fun. :-/ I’ve managed to eliminate all the various errors about pkcs-11-trust being missing even though there is no i686 package for p11-trust-kit on 64 bit CentOS (manually extracted the RPM and installed the file it was looking for). Got rid of the ntlm_auth error as well. The last one remaining is the error reported in this thread. I also had an issue where even though I used the multihome option, it would try to make client connections using my VPN IP. The only way to stop that was to shut down the VPN. I had the multihome set to my external address and that’s what the server would listen on. But upon trying to connect, all client connections had the VPN address instead. How do you force it to use a specific NIC? External NIC is venet:0, while the VPN is tun0, so if I could specify venet:0, that would be awesome. I just resolved a the pkcs and ntlm_auth errors, so I’m checking now if the server still becomes unresponsive after some time (which is what was happening before, just like it was to the OP)


Log in to reply