Could not download needed packages error.



  • Hello,

    I made a small map and uploaded it to the workshop. I also added it to my server manually. When I delete the file locally and connect to the server I get the following error:
    Could not download needed packages error. Server did not communicate Workshop

    When I keep the map locally I can play without problems. I tried the BlueHour map, added it manually to the server and it works, downloads on connecting just fine.

    I read the complete documentation on Jira and most probably every forum post about this topic. Can you guys please help me?



  • I get this error when trying to connect to things like the Helms Deep map, not sure whats up with that so I too would love an answer.



  • It’s definitely a problem with the map/cooking/uploading to workshop.



  • This post is deleted!


  • Ok what I did:

    I created the map, built it with production lighting, saved it as AOCFFA-DuelYard_p.upk

    I then cooked the map with these settings:

    The cooking process:

    The resulting files:

    Then I made a new cook script to include the guid:

    The cooking process of that script:

    Then I created the wsinfo file in the “__CMWSDKFiles” folder:

    Edited the upload to Workshop.bat accordingly:

    Ran it:

    Success:

    The file created in the “__CMWSDKFiles” folder:

    Uploaded this to my server and put it in it’s “__CMWSDKFiles” folder:

    Added it to the rotation and started the server:

    Connected while I still have the files in my game directory, yep can play the map:

    Deleted all the map files from my client temporarily and tried to connect:

    So please, I hope someone can spot what I did wrong. As mentioned before, the same process worked with other maps like BlueHour. When connecting to the server it downloaded just fine. Please help!



  • Pushing an update of the map to the Workshop fixed it.

    Edit: Big thanks to everyone I annoyed with this. Especially Rayeon!


Log in to reply