No Servers Showing Up



  • For the past day no servers have been showing up in the server lists of either Medieval Warfare or Deadliest Warrior. I’ve tried everything suggested here and on Steam and nothing has changed. It worked fine yesterday morning, but by that evening no servers were showing up. I don’t know why this is because as far as I’m aware I haven’t installed or changed anything in that time period, so I see no reason as to why the game suddenly refuses to show any servers.

    When attempting to join a friend’s game I got the Steam server viewer to pop up, but it said something like “No response from server.” I can see servers fine in all of the other games on Steam, so why has Chivalry suddenly stopped working? I can play a single player game just fine, but just nothing shows up in the server browser. It just spins for a while saying it’s looking for servers and then nothing.


  • Mod

    Assume there’s nothing odd in the server filter?

    Worth checking if something has crept into your config files, my renaming the config folder in the my documents/my games/chivalry area then reverifying the game cache (it will then redownload a clean copy of the configs)



  • I already tried all that. I’ve redownloaded the game after making sure the configs and the steamapps/common folder were both gone. One of the first things I checked were the filters, and I the filters wouldn’t affect the Steam server dialog box outside the game from connecting to the server my friend was in what I selected to join them from my friends list.



  • Update: I managed to join a game through a friend, even though that didn’t work before. But, the browser is still blank for me. I’ve tried using the third-party server browser, but that just starts up a process but doesn’t open any windows. I’m pretty sure I have the latest version of Java, but I’ll double-check that and try again.



  • Can you just double check and make sure that you aren’t accidentally opted into anything? Right click on game, properties, betas.

    Thanks,



  • I’m not opted into anything.



  • Having the same problem, happening with both Chiv: MW and Deadliest Warrior. I am also not opted into beta. Also, earlier today I tried verifying the local files, and it made me download 1.8Gigs (which sucks with limited monthly internet) and it let me on for awhile. In the middle of a game, it kicked me out and gave me an SDK error, something about not having the right content.



  • If you have a 64 bit system I can recommend using the 64 bit support tick box in the launcher. What I mean is, toggle between alternating 64 bit support and leaving it unticked and see if servers show up on one or the other. That’s what fixed this problem for me.



  • Completely uninstalled the game and made sure all files were gone. Reinstalled. The servers showed up again. Left the game, started it again, servers are now gone again.

    I’m not going to download 6GB+ every time I want to play this game. I can’t afford to, even if I felt like waiting 10 minutes to play every time and resetting all of my settings.



  • On the chance your problem (root cause unknown) is the same as mine, try the following:

    Delete (or rename) the file
    C:\Program Files (x86)\Steam\ClientRegistry.blob

    and re-run the game. My understanding of steam integration is basically zero, so I can only guess why this solves the issue for me. I, however, must perform this step, every time before launching the game or I will have no servers show up in my browser.