UDK Maps To CV Editor?



  • Hi, I have a question concerning UDK vs the Civalry Editor, I am pretty knowledgeable about UDK, and have been creating environments with it for a few years now. I was wondering if anyone knew if transferring a UDK created level over to the CV Editor is possible. If so would you need to cook the level in udk first or just open the .udk file and packages in the CV editor. I have tried the last option already but when trying to load my packages from the content browser I get a null error. I would really appreciate any form of help! Thanks in advance.



  • Hey there FoeJred, we’re glad to see of your interest in creating maps. Chivalry: Medieval Warfare is based on the July 2012 build of Unreal Engine 3, and its editor is nearly the same as the one that ships with the July 2012 UDK. I’m not sure what version of udk your previous map was created in, but I quickly tested bringing in a simple map that I created in the July 2012 UDK. All I did was copy the map file and package files and paste them into the chivalry sdk directory and everything is in working order.



  • Thanks for the great news! I will try saving my map in the July version and see what it does!



  • @FoeJred:

    Thanks for the great news! I will try saving my map in the July version and see what it does!

    I have a UDK map that I want to port to Chivalry in the coming weeks. I’ve tried copying the map and package files to chivalry content folder. But I’m getting the same null error as well. I’m using the May 2014 UDK build. Were you able to solve it using the July 2012 build?



  • Hi, I’ve tried using the July 2012 UDK build as well as the Chivalry MW Editor, to open my UDK map created in the latest version of UDK. But it crashes on trying to load the .upk file, in both cases. So I tried to import the packages and create the map from scratch using my meshes and materials. And that gives me some null error and I can’t access anything inside it. I’ve copied the message below:

    Unable to load package (C:\UDK\UDK-2014-05\UDKGame\Content\Maps\Helm’s Deep\Hornburg_Custom_Assets.upk) PackageVersion 868, MaxExpected 860 : LicenseePackageVersion 0, MaxExpected 0.

    Is there any workaround to this, or do I have to build everything from scratch?


Log in to reply